By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,640 Members | 2,110 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,640 IT Pros & Developers. It's quick & easy.

Error

P: 52
Im trying to generate a report that gets the data from my Database
using DataEnvironment and Datareport.

This is the code I use to open my datareport.

Private Sub mnuCentreListExaminer_Click()
'
DataEnvironment1.Command4 cmbExaminerno.Text '
DataReport4.Show
End Sub

I also used this SQl ststement in my command.

SELECT Exam_Entries.* FROM Exam_Entries WHERE
Exam_Entries.Examiner_No = ?

The datareport shows all relevent data of 1 Examiner,
that Examiner is indicated by the Examiner number from the textbox cmbExaminerno.Text

When I open the Datareport it works.But if I try to open it
again I get this error " Operation is not allowed when the object is open "
I have seen some other people on this website with the same problem who have answers,
and I have tried to adapt those answers to suit me but it still doesn't work

CAN ANYONE PLEASE HELP ME
AND THANX IN ADVANCE
Apr 15 '07 #1
Share this Question
Share on Google+
2 Replies


Dököll
Expert 100+
P: 2,364
Im trying to generate a report that gets the data from my Database
using DataEnvironment and Datareport.

This is the code I use to open my datareport.

Private Sub mnuCentreListExaminer_Click()
'
DataEnvironment1.Command4 cmbExaminerno.Text '
DataReport4.Show
End Sub

I also used this SQl ststement in my command.

SELECT Exam_Entries.* FROM Exam_Entries WHERE
Exam_Entries.Examiner_No = ?

The datareport shows all relevent data of 1 Examiner,
that Examiner is indicated by the Examiner number from the textbox cmbExaminerno.Text

When I open the Datareport it works.But if I try to open it
again I get this error " Operation is not allowed when the object is open "
I have seen some other people on this website with the same problem who have answers,
and I have tried to adapt those answers to suit me but it still doesn't work

CAN ANYONE PLEASE HELP ME
AND THANX IN ADVANCE
I am not sure why you are getting the error. Since you are using data environment, take a look here:

http://www.thescripts.com/forum/thread585465.html

Look towards the botton of the thread...

Good luck with the project, THEAF!

Dököll
Apr 15 '07 #2

P: 52
Thanx Dököll for your answer but im quite new to this and i
didn't fully understand what you ment. could you explain a bit more.

Thanx ALOT
Apr 19 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.