469,609 Members | 1,092 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,609 developers. It's quick & easy.

Re: Focus Doesn't Work With Splitter Panel

One thing I have noticed with .Net is that various controls can have the
same tab index and the app still compiles. I would set the tab index of
your splitter to some large number (larger than a single digit) like 801
or 1001 (I add an extra 1 to make sure it is unique). Then go through
all your controls and check the tab indexes to make sure you don't have
duplicate tab indexes. That will cause tabbing to not work as
advertised. It is a pain but the only workaround I have come up with
(if you already have a lot of controls - well - bummer man! :).

Rich

*** Sent via Developersdex http://www.developersdex.com ***
Nov 6 '08 #1
3 2348
AGP
Already tried that. I have about 10 controls and the splitter panel is index
99.
still no joy.

AGP

"Rich P" <rp*****@aol.comwrote in message
news:uG****************@TK2MSFTNGP02.phx.gbl...
One thing I have noticed with .Net is that various controls can have the
same tab index and the app still compiles. I would set the tab index of
your splitter to some large number (larger than a single digit) like 801
or 1001 (I add an extra 1 to make sure it is unique). Then go through
all your controls and check the tab indexes to make sure you don't have
duplicate tab indexes. That will cause tabbing to not work as
advertised. It is a pain but the only workaround I have come up with
(if you already have a lot of controls - well - bummer man! :).

Rich

*** Sent via Developersdex http://www.developersdex.com ***

Nov 6 '08 #2
Build a test form and add one panel to it - dock the panel to the top of
the testform. Then add one textbox to this panel. Make sure the
tabindex of the panel is like 300 and set the tabindex of the textbox to
0. Now add a splitter and dock it top - so it ends up just under the
panel. Make sure its tabindex is 500. Now run the form and see what
control has the focus on startup. If this form works - then copy all
your controls and code over to it from the other form. Sometimes it is
just something so obscure in a form that you will never find/fix it. So
I start over from scratch.

Rich

*** Sent via Developersdex http://www.developersdex.com ***
Nov 6 '08 #3
AGP
It turns ou a third-party control in the splitpanel makes this behavior
happen.
Ill look at it some more.

AGP

"Rich P" <rp*****@aol.comwrote in message
news:Ol**************@TK2MSFTNGP05.phx.gbl...
Build a test form and add one panel to it - dock the panel to the top of
the testform. Then add one textbox to this panel. Make sure the
tabindex of the panel is like 300 and set the tabindex of the textbox to
0. Now add a splitter and dock it top - so it ends up just under the
panel. Make sure its tabindex is 500. Now run the form and see what
control has the focus on startup. If this form works - then copy all
your controls and code over to it from the other form. Sometimes it is
just something so obscure in a form that you will never find/fix it. So
I start over from scratch.

Rich

*** Sent via Developersdex http://www.developersdex.com ***

Nov 8 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Krish | last post: by
4 posts views Thread by Peter | last post: by
5 posts views Thread by Sam | last post: by
3 posts views Thread by Dennis | last post: by
2 posts views Thread by Istvan | last post: by
3 posts views Thread by Jeffrey Walton | last post: by
8 posts views Thread by Mr. X. | last post: by
reply views Thread by devrayhaan | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.