By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,441 Members | 1,831 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,441 IT Pros & Developers. It's quick & easy.

Cannot connect database

P: n/a
Dear All,

I have posted my question as below.
But no answers, hope it can found here.

http://forums.microsoft.com/msdn/Sho...69349810029562
Jun 27 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Raymond,

Most of us don't like to open a link especially not when it is from somebody
from a chinese area because of the much malafide spam which as been in these
newsgroups from that area. In this case it is obvious that it is not, but a
lot of people don't even look at that at it is from China (Hong Kong) in
this case

You just can copy and paste
---------------------------------------
I am using the following connectionstring in vb.net 2005 program.
<add key="SGSQLConn" value="Data Source=10.1.1.91;Initial
catalog=Testing;Persist Security Info=True;User ID=raymond;Password=abc"/>

(1) It cannot open the connection and prompt the error that <cannot open
database "Testing" requested by the login. The login failed. Login failed
for user 'raymond'.>

(2) When I remove initial catalog, connection can be open and when fill to
the dataset, it prompt error that table no found.

(3) When put in asp.net program with altering connectionstring to be usable
in sqldatastore using same userid and password, I can connect to the
database and see the tables.

(4) Using same userid and password and ipaddress, I can connect to the
database and withdraw data using studio management express.

----------------------------------------------------------------------------------------------

Are you sure you are not using integrated security on with Visual Studio?

Cor



Jun 27 '08 #2

P: n/a
Dear Cor,

Could you tell me how to check this?
The main point is where to change the setting in my computer or in Remote
SQL Server?

Thanks for your help.

Raymond
"Cor Ligthert[MVP]" <no************@planet.nlwrote in message
news:9F**********************************@microsof t.com...
Raymond,

Most of us don't like to open a link especially not when it is from
somebody from a chinese area because of the much malafide spam which as
been in these newsgroups from that area. In this case it is obvious that
it is not, but a lot of people don't even look at that at it is from China
(Hong Kong) in this case

You just can copy and paste
---------------------------------------
I am using the following connectionstring in vb.net 2005 program.
<add key="SGSQLConn" value="Data Source=10.1.1.91;Initial
catalog=Testing;Persist Security Info=True;User ID=raymond;Password=abc"/>

(1) It cannot open the connection and prompt the error that <cannot open
database "Testing" requested by the login. The login failed. Login failed
for user 'raymond'.>

(2) When I remove initial catalog, connection can be open and when fill to
the dataset, it prompt error that table no found.

(3) When put in asp.net program with altering connectionstring to be
usable in sqldatastore using same userid and password, I can connect to
the database and see the tables.

(4) Using same userid and password and ipaddress, I can connect to the
database and withdraw data using studio management express.

----------------------------------------------------------------------------------------------

Are you sure you are not using integrated security on with Visual Studio?

Cor



Jun 27 '08 #3

P: n/a
Raymond,

The first thing you have forever to check in this, is if your SQL database
(the database itself) has the right security settings for what you are
doing.

Cor

"Raymond Chiu" <rc******@yahoo.com.hkschreef in bericht
news:%2****************@TK2MSFTNGP02.phx.gbl...
Dear Cor,

Could you tell me how to check this?
The main point is where to change the setting in my computer or in Remote
SQL Server?

Thanks for your help.

Raymond
"Cor Ligthert[MVP]" <no************@planet.nlwrote in message
news:9F**********************************@microsof t.com...
>Raymond,

Most of us don't like to open a link especially not when it is from
somebody from a chinese area because of the much malafide spam which as
been in these newsgroups from that area. In this case it is obvious that
it is not, but a lot of people don't even look at that at it is from
China (Hong Kong) in this case

You just can copy and paste
---------------------------------------
I am using the following connectionstring in vb.net 2005 program.
<add key="SGSQLConn" value="Data Source=10.1.1.91;Initial
catalog=Testing;Persist Security Info=True;User
ID=raymond;Password=abc"/>

(1) It cannot open the connection and prompt the error that <cannot open
database "Testing" requested by the login. The login failed. Login failed
for user 'raymond'.>

(2) When I remove initial catalog, connection can be open and when fill
to the dataset, it prompt error that table no found.

(3) When put in asp.net program with altering connectionstring to be
usable in sqldatastore using same userid and password, I can connect to
the database and see the tables.

(4) Using same userid and password and ipaddress, I can connect to the
database and withdraw data using studio management express.

----------------------------------------------------------------------------------------------

Are you sure you are not using integrated security on with Visual Studio?

Cor



Jun 27 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.