By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,626 Members | 1,750 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,626 IT Pros & Developers. It's quick & easy.

Visual Studio error - I just don't know what's happening....

P: n/a
I'm doing a Visual Studio Add-In, and I had added an icon (let's say
"MyIcon.ico") to the project resources to use it as icon for the Toolwindow
tab.

Then I decided I didn't want to use that icon anyway, so I removed it and
added "MyBetterIcon.ico" instead.

So far so good. When I debug run my Add-in projekt, the tab shows
"MyBetterIcon" as I want it to.

But in my Toolwindow (Usercontrol) I have a ToolStrip with different
buttons. They of course contain images (but NOT "MyIcon.ico"!!!

When I try to do anything with my toolstrip desing, I get the error message
"Code generation for property 'Items' failed. Error was: 'Could not find
file 'C:\....\MyIcon.ico'

But I had never used that icon for the toolstrip!!!

The Add-in will run, and the toolstrip is shown - but NOT the buttons!

I have tried searching ALL project files for references to "MyIcon.ico" but
cannot find any. I have tried removing the Toolstrip component and added a
new. Didn't help.

What the heck can I do to get my toolstrip buttons back and get rid of
"MyIcon.ico"???
Jul 27 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.