468,545 Members | 1,702 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,545 developers. It's quick & easy.

AccessKey in a Button !

Hi!
I put an & to make an AccessKey in the text property of a Button in MyForm
using the & before the first letter of the text, for example &Spin. I see in
the design mode the S underlined but not in the runtime. Nevertheless the
button is working well when I press the S key! Any suggestion?

Ioannis

Mar 25 '07 #1
3 5412
"Ioannis Stefis" <st*****@otenet.grschrieb:
I put an & to make an AccessKey in the text property of a Button in MyForm
using the & before the first letter of the text, for example &Spin. I see
in
the design mode the S underlined but not in the runtime. Nevertheless the
button is working well when I press the S key! Any suggestion?
This behavior is by design starting with Windows 2000.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://classicvb.org/petition/>

Mar 25 '07 #2
>I put an & to make an AccessKey in the text property of a Button in
>MyForm
using the & before the first letter of the text, for example &Spin. I
see
in
the design mode the S underlined but not in the runtime. Nevertheless
the
button is working well when I press the S key! Any suggestion?
This behavior is by design starting with Windows 2000.

Yeah there is a windows setting to change this.

Right click desktop
Properties
Appearance
Effects

Hide ....[something or other] unless ALT is pressed.

by default you need to press ALT to show the underlines

Rory
Mar 25 '07 #3
Ioannis,

At least with Windows XP there is an option to hide the underlined letters
until the user presses the Alt key.

This setting can be found here:

Display Properties | Appearance | Effects

Hide underlined letters for keyboard navigation until I press the Alt key

Kerry Moorman
"Ioannis Stefis" wrote:
Hi!
I put an & to make an AccessKey in the text property of a Button in MyForm
using the & before the first letter of the text, for example &Spin. I see in
the design mode the S underlined but not in the runtime. Nevertheless the
button is working well when I press the S key! Any suggestion?

Ioannis

Mar 28 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Alex Billerey | last post: by
1 post views Thread by Manan | last post: by
reply views Thread by david cheng | last post: by
1 post views Thread by Andre | last post: by
1 post views Thread by Csaba Gabor | last post: by
5 posts views Thread by Lea GRIS | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.