By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,012 Members | 1,235 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,012 IT Pros & Developers. It's quick & easy.

issue with propertygrid control under Windows Vista

P: n/a

Hi,

I am running VB Express 2005 and have been developing an application
fine under Windows XP, but now I have switched to WIndows Vista I am
getting strange behaviour with the PropertyGrid control. The problem
not only happens on the IWindowsFormsEditorService that I have
provided myself, but on the generic Color dropdown.

When I click the dropdown arrow next to a property in the Grid (be it
Color or one of my own), one of three things happens:

1) the dialog pops up, I select the color or other property, it
closes, and the PropertyGrid refreshes the property value but can
either be immediate or take upto ten seconds to refresh, OR
2) as 1) but the property does not refresh, and when I try and click
the dropdown arrow it does not respond at all, and if I try typing in
a value and pressing Enter, it just reverts back to its initial value
OR
3) the dialog pops up fine, I select the color or other property, and
it closes and refreshes, but this happens rarely

I have to close down my application and restart it, which is very
annoying, but then it just basically ceases functioning after several
uses of the dropdown.

I am running:

Microsoft Visual Studio 2005
Version 8.0.50727.859 (vsvista.050727-8500)

Microsoft .Net Framework
Version 2.0.50727

Has anybody else encountered this? Am I on the correct version?

Thanks,

Richy

Feb 9 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a

"Richy" <mo*********@gmail.comwrote in message
news:11**********************@p10g2000cwp.googlegr oups.com...
>
Hi,

I am running VB Express 2005 and have been developing an application
fine under Windows XP, but now I have switched to WIndows Vista I am
getting strange behaviour with the PropertyGrid control. The problem
not only happens on the IWindowsFormsEditorService that I have
provided myself, but on the generic Color dropdown.

When I click the dropdown arrow next to a property in the Grid (be it
Color or one of my own), one of three things happens:

1) the dialog pops up, I select the color or other property, it
closes, and the PropertyGrid refreshes the property value but can
either be immediate or take upto ten seconds to refresh, OR
2) as 1) but the property does not refresh, and when I try and click
the dropdown arrow it does not respond at all, and if I try typing in
a value and pressing Enter, it just reverts back to its initial value
OR
3) the dialog pops up fine, I select the color or other property, and
it closes and refreshes, but this happens rarely

I have to close down my application and restart it, which is very
annoying, but then it just basically ceases functioning after several
uses of the dropdown.

I am running:

Microsoft Visual Studio 2005
Version 8.0.50727.859 (vsvista.050727-8500)

Microsoft .Net Framework
Version 2.0.50727

Has anybody else encountered this? Am I on the correct version?

Thanks,

Richy
You are running this under an Adminstrator account, aren't you?

Robin S.
Ts'i mahnu uterna ot twan ot geifur hingts uto.
Feb 10 '07 #2

P: n/a
vista doesn't support VB 2005

I would go back to Vb6

-Tom

Feb 10 '07 #3

P: n/a
Aaron,

You've already blown your cover. hehehehe Now go blow yer nose and stop
bothering honest folks trying to get honest answers.

Bruce

"punjab_tom" <pu********@hotmail.comwrote in message
news:11**********************@v45g2000cwv.googlegr oups.com...
vista doesn't support VB 2005

I would go back to Vb6

-Tom

Feb 10 '07 #4

P: n/a

I am running it from a shortcut on my desktop, which has had the
Compatibility properties changed so that the Privilege Level is ticked
for Run This Program As An Administator.

Richy
>
You are running this under an Adminstrator account, aren't you?

Robin S.
Ts'i mahnu uterna ot twan ot geifur hingts uto.- Hide quoted text -

- Show quoted text -

Feb 10 '07 #5

P: n/a
DOTNOT doesn't work on Vista

I would suggest looking to a new vendor because MS gave up on VB


On Feb 9, 5:58 pm, "Bruce W. Darby" <kraco...@atcomcast.netwrote:
Aaron,

You've already blown your cover. hehehehe Now go blow yer nose and stop
bothering honest folks trying to get honest answers.

Bruce

"punjab_tom" <punjab_...@hotmail.comwrote in message

news:11**********************@v45g2000cwv.googlegr oups.com...
vista doesn't support VB 2005
I would go back to Vb6
-Tom- Hide quoted text -

- Show quoted text -

Feb 14 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.