By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,142 Members | 1,907 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,142 IT Pros & Developers. It's quick & easy.

Problem using serial port in vb2005

P: n/a
Jan
Hello,

I want to send some simple strings to com1 using vb2005. I want to read it
in Hyperterminal.
I succeeded to send some data en read it in Hyperterminal, only the data I
received is not the data I send.

This is the code i used:

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles Button1.Click
SendSerialData()
End Sub

Sub SendSerialData()
Dim data As String = "x"

' Send strings to a serial port.
Using com1 As IO.Ports.SerialPort =
My.Computer.Ports.OpenSerialPort("COM1", 2400, IO.Ports.Parity.None, 8, 1)

com1.WriteLine(data)
End Using
End Sub

Is there something I forgot?
The settings of the serial port I also used for hyperterminal.

Thank you very much for even reading my question
Dec 4 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Jan wrote:
I want to send some simple strings to com1 using vb2005. I want to read it
in Hyperterminal.
I succeeded to send some data en read it in Hyperterminal, only the data I
received is not the data I send.
You will have to be more specific about what went wrong. How is the
data you received different than what you sent? Is it *completely*
different? Or are you just missing some information?

You said the settings in Hyperterminal and the serial port were the
same. Are you using the same handshaking? Is it hardware handshaking
or are you using XOn/XOff? How much data are you sending?

Chris

Dec 4 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.