By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,642 Members | 1,474 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,642 IT Pros & Developers. It's quick & easy.

Problem sending mail

P: n/a
I a m trying to send e-mails using the system.net.mail in framework2. I have
IIS installed on my test box and the smtp service is started. I can use
outlook on that box to send and receive my e-mails OK, my firewall ports 25
and 53 are open (using isa server 2004 as firewall), the local machine (Win
XP Pro SP2) firewall is off.

My code creates the e-mail messages OK, but they get stuck in the queue
folder and never go out. I've spent the last week googling and looking for
info on this problem but I can't get it fixed.

I've used a smtp testing program downloaded from the net and it does the
same thing. It creates the messages and they just stay stuck in the queue.

I am desperate to try to get this thing working. I had apps that send
e-mails automatically before but since I started working with the .net stuff
and framework 2 everything is screwed up!

Any help would be GREATLY appreciated.
I really need to know exactly what to do to get these messages unstuck from
the queue.

Thanks
Bob
Nov 7 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
There are two possible reasons that I can see...
Lets get the first one out of the way. ISA Server... do you have the
Client Software installed? If so, you would need to make certain that
ISA is configured to allow the traffic from the local network to the
wide network.
If not, I would assume you already have ISA configured to allow
anonymous traffic.

That said,
Most ISP's will disallow users to run their own SMTP server. In my
neck of the woods, the right is usually reserved for people with
business accounts. You should try firing it out of your ISP's SMTP
server first, and make sure that it doesn't work that way. I think the
reason ISPs dont' allow this is to help prevent Virus's form spreading
and of course spam.
On Nov 7, 4:39 pm, "Robert Dufour" <bduf...@sgiims.comwrote:
I a m trying to send e-mails using the system.net.mail in framework2. I have
IIS installed on my test box and the smtp service is started. I can use
outlook on that box to send and receive my e-mails OK, my firewall ports 25
and 53 are open (using isa server 2004 as firewall), the local machine (Win
XP Pro SP2) firewall is off.

My code creates the e-mail messages OK, but they get stuck in the queue
folder and never go out. I've spent the last week googling and looking for
info on this problem but I can't get it fixed.

I've used a smtp testing program downloaded from the net and it does the
same thing. It creates the messages and they just stay stuck in the queue.

I am desperate to try to get this thing working. I had apps that send
e-mails automatically before but since I started working with the .net stuff
and framework 2 everything is screwed up!

Any help would be GREATLY appreciated.
I really need to know exactly what to do to get these messages unstuck from
the queue.

Thanks
Bob
Nov 7 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.