By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,219 Members | 2,242 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,219 IT Pros & Developers. It's quick & easy.

Cant load a crystal report after publishing it and installing on another machine?

P: n/a
I created this test project and published it. I then tried installing
it on another machine and it installs fine. but when I go to open the
crystalreportviewer to show my created report I get an error saying it
cant and load the file. when I run it on my machine it works fine, its
like when I build the project the crystal report is not getting
included. Does anyone know where the setting is to include the crystal
report in the build or publishing of the application within vb.net
2005. Here is the code I have in my crystal report viewer if it helps.

Private Sub FormCrRptViewer_Load(ByVal sender As System.Object, ByVal e
As System.EventArgs) Handles MyBase.Load

reportDocument1.Load(Application.StartupPath &
"\CrystalReport3.rpt")

Dim dv As DataView

dv = New DataView(Form1.AccuLogicDataSet1.WorkList)

reportDocument1.SetDataSource(dv)

reportDocument1.Refresh()
With CrystalReportViewer1 'ReportViewer1

.DisplayGroupTree = True

.DisplayToolbar = True

.ReportSource = reportDocument1

.Refresh()
End With

End Sub

Nov 3 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.