By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,723 Members | 1,138 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,723 IT Pros & Developers. It's quick & easy.

How to turn off Managed Debugging Assistant in VB.NET (2005)

P: n/a
I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.
Oct 30 '06 #1
Share this Question
Share on Google+
6 Replies

P: n/a
I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.

It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst

================================================== ===
Rob R. Ainscough wrote:
I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.
Oct 30 '06 #2

P: n/a
Are you talking from the Menu ? No such option on my Menu? My options are:

Windows
Continue
Break All
Stop Debugging
Detach All
Terminate All
Restart...
Attach to Process
Step Over
Toggle Breakpoint
Delete All Breakpoints
Disable All Breakpoints

Now if you're talking about Tools | Options and select Debugging -- which
one is it?

Is it "Enable the exception assistant" ?? I believe I want that
enabled...any further clues.

Thanks, Rob.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11**********************@k70g2000cwa.googlegr oups.com...
>I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.

It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst

================================================== ===
Rob R. Ainscough wrote:
>I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.

Oct 30 '06 #3

P: n/a
Not sure about yours, but My Visual Studio 2005 main pulldown menus are
File, Edit, View, Project, Build, Debug, Data, Tools, Window,
Community, and Help. It's very strange that you don't even have a File
and Edit menu items -- that's virtually universal in all Windows
applications. I don't even have a Debugging item in the dialog box
that appears when I do Tools/Options. What version of VS are you
using? Are you SURE it's VS2005? Are you talking about a toolbar
rather than a menu bar possibly?

Now, if you then drop down the Debug pulldown menu from the main VS2005
menubar, you'll see Exceptions... as one of the items you can select.
Select that and you can turn off the Assistant.
Good luck,
ImageAnalyst.

================================================== =
Rob R. Ainscough wrote:
Are you talking from the Menu ? No such option on my Menu? My options are:

Windows
Continue
Break All
Stop Debugging
Detach All
Terminate All
Restart...
Attach to Process
Step Over
Toggle Breakpoint
Delete All Breakpoints
Disable All Breakpoints

Now if you're talking about Tools | Options and select Debugging -- which
one is it?

Is it "Enable the exception assistant" ?? I believe I want that
enabled...any further clues.

Thanks, Rob.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11**********************@k70g2000cwa.googlegr oups.com...
I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.

It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst

================================================== ===
Rob R. Ainscough wrote:
I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.
Oct 31 '06 #4

P: n/a
I was listing the options from my under my Debug menu item -- yes of course
I have File, Edit, View... etc.

No "Exceptions..." listed under my Debug menu.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11*********************@f16g2000cwb.googlegro ups.com...
Not sure about yours, but My Visual Studio 2005 main pulldown menus are
File, Edit, View, Project, Build, Debug, Data, Tools, Window,
Community, and Help. It's very strange that you don't even have a File
and Edit menu items -- that's virtually universal in all Windows
applications. I don't even have a Debugging item in the dialog box
that appears when I do Tools/Options. What version of VS are you
using? Are you SURE it's VS2005? Are you talking about a toolbar
rather than a menu bar possibly?

Now, if you then drop down the Debug pulldown menu from the main VS2005
menubar, you'll see Exceptions... as one of the items you can select.
Select that and you can turn off the Assistant.
Good luck,
ImageAnalyst.

================================================== =
Rob R. Ainscough wrote:
>Are you talking from the Menu ? No such option on my Menu? My options
are:

Windows
Continue
Break All
Stop Debugging
Detach All
Terminate All
Restart...
Attach to Process
Step Over
Toggle Breakpoint
Delete All Breakpoints
Disable All Breakpoints

Now if you're talking about Tools | Options and select Debugging -- which
one is it?

Is it "Enable the exception assistant" ?? I believe I want that
enabled...any further clues.

Thanks, Rob.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11**********************@k70g2000cwa.googleg roups.com...
>I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.

It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst

================================================== ===
Rob R. Ainscough wrote:
I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.

Nov 1 '06 #5

P: n/a
Try typing Ctrl+Alt+E. That's what they have as the shortcut for it.
My debugging menu has, when looking at a form
Windows
Start Debugging
Step Into
Step Over
Exceptions...
Toggle Breakpoint
New Breakpoint
Delete All breakpoints

When stopped at a breakpoint in code:
Windows
Continue
Break all
Stop debugging
Step into
Step over
Step out
Quick Watch
Exceptions
Toggle Breakpoint
New Breakpoint
Delete All breakpoints

I have no idea why your is different and the Exceptions item is
missing, but try the keyboard shortcut and see if that works. Are you
doing a standard Windows executable or some other kind of project, like
an ActiveX server or something?
Regards,
ImageAnalyst
Rob R. Ainscough wrote:
I was listing the options from my under my Debug menu item -- yes of course
I have File, Edit, View... etc.

No "Exceptions..." listed under my Debug menu.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11*********************@f16g2000cwb.googlegro ups.com...
Not sure about yours, but My Visual Studio 2005 main pulldown menus are
File, Edit, View, Project, Build, Debug, Data, Tools, Window,
Community, and Help. It's very strange that you don't even have a File
and Edit menu items -- that's virtually universal in all Windows
applications. I don't even have a Debugging item in the dialog box
that appears when I do Tools/Options. What version of VS are you
using? Are you SURE it's VS2005? Are you talking about a toolbar
rather than a menu bar possibly?

Now, if you then drop down the Debug pulldown menu from the main VS2005
menubar, you'll see Exceptions... as one of the items you can select.
Select that and you can turn off the Assistant.
Good luck,
ImageAnalyst.

================================================== =
Rob R. Ainscough wrote:
Are you talking from the Menu ? No such option on my Menu? My options
are:

Windows
Continue
Break All
Stop Debugging
Detach All
Terminate All
Restart...
Attach to Process
Step Over
Toggle Breakpoint
Delete All Breakpoints
Disable All Breakpoints

Now if you're talking about Tools | Options and select Debugging -- which
one is it?

Is it "Enable the exception assistant" ?? I believe I want that
enabled...any further clues.

Thanks, Rob.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11**********************@k70g2000cwa.googlegr oups.com...
I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.

It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst

================================================== ===
Rob R. Ainscough wrote:
I can't seem to locate the appropriate area in VS 2005 where I can
accomplish this -- is this a C# only option?

Thanks, Rob.
Nov 1 '06 #6

P: n/a
I have no idea why your is different and the Exceptions item is
missing, but try the keyboard shortcut and see if that works
It may have gotten removed by accident or perhaps magic :-) Anyways, if
you want to add it back then goto Tools...Customize and click the
Commands tab. Then click the Rearrange commands button. Select the
"Menu Bar:" radio and then select Debug from the drop down. Click the
Add... button and select "Debug" from the left listbox and then
"Exceptions" in the right list box and click OK. That should add it
back to the debug menu.

Thanks,

Seth Rowe
ImageAnalyst wrote:
Try typing Ctrl+Alt+E. That's what they have as the shortcut for it.
My debugging menu has, when looking at a form
Windows
Start Debugging
Step Into
Step Over
Exceptions...
Toggle Breakpoint
New Breakpoint
Delete All breakpoints

When stopped at a breakpoint in code:
Windows
Continue
Break all
Stop debugging
Step into
Step over
Step out
Quick Watch
Exceptions
Toggle Breakpoint
New Breakpoint
Delete All breakpoints

I have no idea why your is different and the Exceptions item is
missing, but try the keyboard shortcut and see if that works. Are you
doing a standard Windows executable or some other kind of project, like
an ActiveX server or something?
Regards,
ImageAnalyst
Rob R. Ainscough wrote:
I was listing the options from my under my Debug menu item -- yes of course
I have File, Edit, View... etc.

No "Exceptions..." listed under my Debug menu.

"ImageAnalyst" <ha******@hotmail.comwrote in message
news:11*********************@f16g2000cwb.googlegro ups.com...
Not sure about yours, but My Visual Studio 2005 main pulldown menus are
File, Edit, View, Project, Build, Debug, Data, Tools, Window,
Community, and Help. It's very strange that you don't even have a File
and Edit menu items -- that's virtually universal in all Windows
applications. I don't even have a Debugging item in the dialog box
that appears when I do Tools/Options. What version of VS are you
using? Are you SURE it's VS2005? Are you talking about a toolbar
rather than a menu bar possibly?
>
Now, if you then drop down the Debug pulldown menu from the main VS2005
menubar, you'll see Exceptions... as one of the items you can select.
Select that and you can turn off the Assistant.
Good luck,
ImageAnalyst.
>
================================================== =
Rob R. Ainscough wrote:
>Are you talking from the Menu ? No such option on my Menu? My options
>are:
>>
>Windows
>Continue
>Break All
>Stop Debugging
>Detach All
>Terminate All
>Restart...
>Attach to Process
>Step Over
>Toggle Breakpoint
>Delete All Breakpoints
>Disable All Breakpoints
>>
>Now if you're talking about Tools | Options and select Debugging -- which
>one is it?
>>
>Is it "Enable the exception assistant" ?? I believe I want that
>enabled...any further clues.
>>
>Thanks, Rob.
>>
>"ImageAnalyst" <ha******@hotmail.comwrote in message
>news:11**********************@k70g2000cwa.googleg roups.com...
>I know - it's hard to find. It is there with Visual Studio VB.Net - it
just takes a while to find it.
>
It's under the Debug/Exceptions... pulldown menu item. Sometimes I get
weird errors about LoaderLock with that set so I go into the Managed
Debugging Assistants area and uncheck the LoaderLock checkbox. Seems
to occur sometimes with certain OCX'es I use. Unchecking makes the
nagging errors go away with no other problems.
Regards,
ImageAnalyst
>
================================================== ===
Rob R. Ainscough wrote:
>I can't seem to locate the appropriate area in VS 2005 where I can
>accomplish this -- is this a C# only option?
>>
>Thanks, Rob.
>
>
Nov 1 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.