469,914 Members | 2,184 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,914 developers. It's quick & easy.

VS2002 windows service crashing under Windows 2003 SP1

Hi,

I have long time ago written windows service (VS2002) which is working fine
on Windows 2000 server for 4 years. After installing service on Windows 2003
SP1 service crashing every time with same System.StackOverflow exception.
Please help me with this if you can?
[thread 0xf38] Thread created.

Unable to determine existence of prolog, if any

[thread 0x3f0] Thread created.

[thread 0xd8c] Thread created.

[thread 0xe64] Thread created.

[thread 0xee8] Thread created.

[thread 0x3f0] Unhandled exception generated: (0x010e1074)
<System.StackOverflow

Exception>

_className=<null>

_exceptionMethod=<null>

_exceptionMethodString=<null>

_message=<null>

_innerException=<null>

_helpURL=<null>

_stackTrace=<null>

_stackTraceString=<null>

_remoteStackTraceString=<null>

_remoteStackIndex=0x00000000

_HResult=0x800703e9

_source=<null>

_xptrs=0x00000000

_xcode=0xe0434f4d

Thread 0x3f0 R 0x7C82ED54: <unknown>

(cordbg)
Apr 18 '06 #1
4 1976
Debug any recursive routines

"Lenny Shprekher" <Lenny Sh*******@discussions.microsoft.com> wrote in
message news:47**********************************@microsof t.com...
Hi,

I have long time ago written windows service (VS2002) which is working
fine
on Windows 2000 server for 4 years. After installing service on Windows
2003
SP1 service crashing every time with same System.StackOverflow exception.
Please help me with this if you can?
[thread 0xf38] Thread created.

Unable to determine existence of prolog, if any

[thread 0x3f0] Thread created.

[thread 0xd8c] Thread created.

[thread 0xe64] Thread created.

[thread 0xee8] Thread created.

[thread 0x3f0] Unhandled exception generated: (0x010e1074)
<System.StackOverflow

Exception>

_className=<null>

_exceptionMethod=<null>

_exceptionMethodString=<null>

_message=<null>

_innerException=<null>

_helpURL=<null>

_stackTrace=<null>

_stackTraceString=<null>

_remoteStackTraceString=<null>

_remoteStackIndex=0x00000000

_HResult=0x800703e9

_source=<null>

_xptrs=0x00000000

_xcode=0xe0434f4d

Thread 0x3f0 R 0x7C82ED54: <unknown>

(cordbg)

Apr 18 '06 #2
If that was the issue than why it works in production under Win 2000 for 4
years fine?
"Jeff Dillon" wrote:
Debug any recursive routines

"Lenny Shprekher" <Lenny Sh*******@discussions.microsoft.com> wrote in
message news:47**********************************@microsof t.com...
Hi,

I have long time ago written windows service (VS2002) which is working
fine
on Windows 2000 server for 4 years. After installing service on Windows
2003
SP1 service crashing every time with same System.StackOverflow exception.
Please help me with this if you can?
[thread 0xf38] Thread created.

Unable to determine existence of prolog, if any

[thread 0x3f0] Thread created.

[thread 0xd8c] Thread created.

[thread 0xe64] Thread created.

[thread 0xee8] Thread created.

[thread 0x3f0] Unhandled exception generated: (0x010e1074)
<System.StackOverflow

Exception>

_className=<null>

_exceptionMethod=<null>

_exceptionMethodString=<null>

_message=<null>

_innerException=<null>

_helpURL=<null>

_stackTrace=<null>

_stackTraceString=<null>

_remoteStackTraceString=<null>

_remoteStackIndex=0x00000000

_HResult=0x800703e9

_source=<null>

_xptrs=0x00000000

_xcode=0xe0434f4d

Thread 0x3f0 R 0x7C82ED54: <unknown>

(cordbg)


Apr 18 '06 #3
Exactly. Do nothing, problem persists. Follow advice, learn something!

"Lenny Shprekher" <Le************@discussions.microsoft.com> wrote in
message news:31**********************************@microsof t.com...
If that was the issue than why it works in production under Win 2000 for 4
years fine?
"Jeff Dillon" wrote:
Debug any recursive routines

"Lenny Shprekher" <Lenny Sh*******@discussions.microsoft.com> wrote in
message news:47**********************************@microsof t.com...
> Hi,
>
> I have long time ago written windows service (VS2002) which is working
> fine
> on Windows 2000 server for 4 years. After installing service on Windows
> 2003
> SP1 service crashing every time with same System.StackOverflow
> exception.
> Please help me with this if you can?
>
>
> [thread 0xf38] Thread created.
>
> Unable to determine existence of prolog, if any
>
> [thread 0x3f0] Thread created.
>
> [thread 0xd8c] Thread created.
>
> [thread 0xe64] Thread created.
>
> [thread 0xee8] Thread created.
>
> [thread 0x3f0] Unhandled exception generated: (0x010e1074)
> <System.StackOverflow
>
> Exception>
>
> _className=<null>
>
> _exceptionMethod=<null>
>
> _exceptionMethodString=<null>
>
> _message=<null>
>
> _innerException=<null>
>
> _helpURL=<null>
>
> _stackTrace=<null>
>
> _stackTraceString=<null>
>
> _remoteStackTraceString=<null>
>
> _remoteStackIndex=0x00000000
>
> _HResult=0x800703e9
>
> _source=<null>
>
> _xptrs=0x00000000
>
> _xcode=0xe0434f4d
>
>
>
> Thread 0x3f0 R 0x7C82ED54: <unknown>
>
> (cordbg)
>
>


Apr 18 '06 #4
You could spend month debugging and rewriting, but logically this is wrong
and might cost company a lot $. How could hypothetically bad code work for 4
years and now I can't even create new blank windows service project under
Windows 2003 Sp1 using VS2002. Don't you think this is not code issue?
Does Windows 2003 SP1 support VS2002 development platform at all? Could you
try creating blank windows service project under Windows 2003 SP1?


"Jeff Dillon" wrote:
Exactly. Do nothing, problem persists. Follow advice, learn something!

"Lenny Shprekher" <Le************@discussions.microsoft.com> wrote in
message news:31**********************************@microsof t.com...
If that was the issue than why it works in production under Win 2000 for 4
years fine?
"Jeff Dillon" wrote:
Debug any recursive routines

"Lenny Shprekher" <Lenny Sh*******@discussions.microsoft.com> wrote in
message news:47**********************************@microsof t.com...
> Hi,
>
> I have long time ago written windows service (VS2002) which is working
> fine
> on Windows 2000 server for 4 years. After installing service on Windows
> 2003
> SP1 service crashing every time with same System.StackOverflow
> exception.
> Please help me with this if you can?
>
>
> [thread 0xf38] Thread created.
>
> Unable to determine existence of prolog, if any
>
> [thread 0x3f0] Thread created.
>
> [thread 0xd8c] Thread created.
>
> [thread 0xe64] Thread created.
>
> [thread 0xee8] Thread created.
>
> [thread 0x3f0] Unhandled exception generated: (0x010e1074)
> <System.StackOverflow
>
> Exception>
>
> _className=<null>
>
> _exceptionMethod=<null>
>
> _exceptionMethodString=<null>
>
> _message=<null>
>
> _innerException=<null>
>
> _helpURL=<null>
>
> _stackTrace=<null>
>
> _stackTraceString=<null>
>
> _remoteStackTraceString=<null>
>
> _remoteStackIndex=0x00000000
>
> _HResult=0x800703e9
>
> _source=<null>
>
> _xptrs=0x00000000
>
> _xcode=0xe0434f4d
>
>
>
> Thread 0x3f0 R 0x7C82ED54: <unknown>
>
> (cordbg)
>
>


Apr 18 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by thdevdex | last post: by
2 posts views Thread by cd | last post: by
7 posts views Thread by Mike | last post: by
3 posts views Thread by TLin2100 | last post: by
10 posts views Thread by Ger | last post: by
reply views Thread by Charles Leonard | last post: by
4 posts views Thread by Shawn Meyer | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.