By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,694 Members | 1,307 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,694 IT Pros & Developers. It's quick & easy.

Installing published application fails

P: n/a
Hi everybody,

[I'm using VS 2005]

I tried to publich my application to a simple file location. (no online
publishing or anything like that.)

Running the setup that VS generates for me works fine on my machine but when
I try to copy the generated setup files to another machine and start it, it
gives me this error:

"System Update Required"
Unable to install or run the application. The application requires that
assembly Microsoft.VisualBasic Version 2.0.0.1 be installed in the Global
Assembly Cache (GAC) first.

Is there any way to have the setup know what kinds of system updates are
required for the current machine and update it automatically? I have no clue
how to install this VB Version without having to install the whole VS, SDK
and what else ... The customer should simply have an executable setup he
double-clicks and that works ...

Help is very much appriciated,
Thanx, Joe
Feb 20 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi Joe,

AFAIK, the assembly version of Microsoft.VisualBasic is 8.0.0.0 and the file
version is 8.0.50727.42, so I am not sure why it is requiring 2.0.0.1.

Is the .NET Framework 2.0 (not the SDK or VS, just the .NET Framework
redistributable) installed on the target machine? See:

http://www.microsoft.com/downloads/d...DisplayLang=en
--

Best regards,

Carlos J. Quintero

MZ-Tools: Productivity add-ins for Visual Studio
You can code, design and document much faster:
http://www.mztools.com

"Josef Brunner" <jo**@newsgroups.nospam> escribiˇ en el mensaje
news:%2****************@tk2msftngp13.phx.gbl...
Hi everybody,

[I'm using VS 2005]

I tried to publich my application to a simple file location. (no online
publishing or anything like that.)

Running the setup that VS generates for me works fine on my machine but
when I try to copy the generated setup files to another machine and start
it, it gives me this error:

"System Update Required"
Unable to install or run the application. The application requires that
assembly Microsoft.VisualBasic Version 2.0.0.1 be installed in the Global
Assembly Cache (GAC) first.

Is there any way to have the setup know what kinds of system updates are
required for the current machine and update it automatically? I have no
clue how to install this VB Version without having to install the whole
VS, SDK and what else ... The customer should simply have an executable
setup he double-clicks and that works ...

Help is very much appriciated,
Thanx, Joe

Feb 20 '06 #2

P: n/a
Hi,

thank for the fast reply!

I installed the framework from the given link. I still get the same error
code.

It is an XP Professional 2002 Service Pack 2 machine with automatic updates
enabled...

Any more ideas?
Thank you again,
Josef
"Carlos J. Quintero [VB MVP]" <ca*****@NOSPAMsogecable.com> schrieb im
Newsbeitrag news:ei**************@tk2msftngp13.phx.gbl...
Hi Joe,

AFAIK, the assembly version of Microsoft.VisualBasic is 8.0.0.0 and the
file version is 8.0.50727.42, so I am not sure why it is requiring
2.0.0.1.

Is the .NET Framework 2.0 (not the SDK or VS, just the .NET Framework
redistributable) installed on the target machine? See:

http://www.microsoft.com/downloads/d...DisplayLang=en
--

Best regards,

Carlos J. Quintero

MZ-Tools: Productivity add-ins for Visual Studio
You can code, design and document much faster:
http://www.mztools.com

"Josef Brunner" <jo**@newsgroups.nospam> escribiˇ en el mensaje
news:%2****************@tk2msftngp13.phx.gbl...
Hi everybody,

[I'm using VS 2005]

I tried to publich my application to a simple file location. (no online
publishing or anything like that.)

Running the setup that VS generates for me works fine on my machine but
when I try to copy the generated setup files to another machine and start
it, it gives me this error:

"System Update Required"
Unable to install or run the application. The application requires that
assembly Microsoft.VisualBasic Version 2.0.0.1 be installed in the Global
Assembly Cache (GAC) first.

Is there any way to have the setup know what kinds of system updates are
required for the current machine and update it automatically? I have no
clue how to install this VB Version without having to install the whole
VS, SDK and what else ... The customer should simply have an executable
setup he double-clicks and that works ...

Help is very much appriciated,
Thanx, Joe


Feb 20 '06 #3

P: n/a
Hi again,

even after installing VS 2005 on the target machine the setup fails to run
with the same error message. And there it comes: even when starting the
project within the VS 2005 environment it has the same error code.

Maybe I'm doing something wrong with configuration when publishing the
application. Since everything is "new" in VS 2005 and I could not find a
detailed description of how to correctly publish an application (for example
when I add some xml files as resources to the application it won't give me
the choice to include these files into the setup program) maybe it would
work just fine if I'd get all configurations done just wright.

Hopefully someone can "guide" me to the solution,

Kurt

"Josef Brunner" <jo**@newsgroups.nospam> schrieb im Newsbeitrag
news:eI**************@TK2MSFTNGP10.phx.gbl...
Hi,

thank for the fast reply!

I installed the framework from the given link. I still get the same error
code.

It is an XP Professional 2002 Service Pack 2 machine with automatic
updates enabled...

Any more ideas?
Thank you again,
Josef
"Carlos J. Quintero [VB MVP]" <ca*****@NOSPAMsogecable.com> schrieb im
Newsbeitrag news:ei**************@tk2msftngp13.phx.gbl...
Hi Joe,

AFAIK, the assembly version of Microsoft.VisualBasic is 8.0.0.0 and the
file version is 8.0.50727.42, so I am not sure why it is requiring
2.0.0.1.

Is the .NET Framework 2.0 (not the SDK or VS, just the .NET Framework
redistributable) installed on the target machine? See:

http://www.microsoft.com/downloads/d...DisplayLang=en
--

Best regards,

Carlos J. Quintero

MZ-Tools: Productivity add-ins for Visual Studio
You can code, design and document much faster:
http://www.mztools.com

"Josef Brunner" <jo**@newsgroups.nospam> escribiˇ en el mensaje
news:%2****************@tk2msftngp13.phx.gbl...
Hi everybody,

[I'm using VS 2005]

I tried to publich my application to a simple file location. (no online
publishing or anything like that.)

Running the setup that VS generates for me works fine on my machine but
when I try to copy the generated setup files to another machine and
start it, it gives me this error:

"System Update Required"
Unable to install or run the application. The application requires that
assembly Microsoft.VisualBasic Version 2.0.0.1 be installed in the
Global Assembly Cache (GAC) first.

Is there any way to have the setup know what kinds of system updates are
required for the current machine and update it automatically? I have no
clue how to install this VB Version without having to install the whole
VS, SDK and what else ... The customer should simply have an executable
setup he double-clicks and that works ...

Help is very much appriciated,
Thanx, Joe



Feb 20 '06 #4

P: n/a
I found the solution:

I uninstalled the LINQ Tech Preview software package that I just installed a
couple of days ago, rebuild the project, published it and installed it
successfully...lucky me!

BTW: Why is the generated setup installing the software in such a crazy
directory (c:documents and settings/user/local
.../Apps/v2.0/lkjafd÷lkjsafd/...

??

Joe

"Carlos J. Quintero [VB MVP]" <ca*****@NOSPAMsogecable.com> schrieb im
Newsbeitrag news:ei**************@tk2msftngp13.phx.gbl...
Hi Joe,

AFAIK, the assembly version of Microsoft.VisualBasic is 8.0.0.0 and the
file version is 8.0.50727.42, so I am not sure why it is requiring
2.0.0.1.

Is the .NET Framework 2.0 (not the SDK or VS, just the .NET Framework
redistributable) installed on the target machine? See:

http://www.microsoft.com/downloads/d...DisplayLang=en
--

Best regards,

Carlos J. Quintero

MZ-Tools: Productivity add-ins for Visual Studio
You can code, design and document much faster:
http://www.mztools.com

"Josef Brunner" <jo**@newsgroups.nospam> escribiˇ en el mensaje
news:%2****************@tk2msftngp13.phx.gbl...
Hi everybody,

[I'm using VS 2005]

I tried to publich my application to a simple file location. (no online
publishing or anything like that.)

Running the setup that VS generates for me works fine on my machine but
when I try to copy the generated setup files to another machine and start
it, it gives me this error:

"System Update Required"
Unable to install or run the application. The application requires that
assembly Microsoft.VisualBasic Version 2.0.0.1 be installed in the Global
Assembly Cache (GAC) first.

Is there any way to have the setup know what kinds of system updates are
required for the current machine and update it automatically? I have no
clue how to install this VB Version without having to install the whole
VS, SDK and what else ... The customer should simply have an executable
setup he double-clicks and that works ...

Help is very much appriciated,
Thanx, Joe


Feb 20 '06 #5

P: n/a
Hi Josef,

I am glad that you have found the solution.
Also this directory is a user specific ones, so the application will not
confused with another ones.
This is how Smart Client doing. That way another smart client will not have
the confliction.

Commonly we did not need to care where smart client deploy its application.
Because the smart client will check for update when it is lauched.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Feb 21 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.