By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,168 Members | 2,548 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,168 IT Pros & Developers. It's quick & easy.

Validating Event Not Firing

P: n/a
Hi,

I am having a problem where the validating event of a text box is not
always firing. I am using vb.net 2003.

I have an MDI application, one of the child forms contains a tab control
which has on the first tab a number of text boxes (amongst other
things). Each of these text boxes has code in their validating event.
If you open the form click or tab to one of the text boxes, enter your
text then tab off validation fires as expected every time. However if
you open another child window (any of the other child windows has the
same effect) and then return to the original text box on the original
form and then leave that text box the validating event never fires.

Any help would be gratefully appreciated.

Cheers,

Ian
Nov 21 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Ian,

If I understand you right, than this is a known bug.

Cor
Nov 21 '05 #2

P: n/a
Cor,

I have the other case. Do not know if it is bug also.

I have regularexpress validate on my text box. It works for URL as
localhost/blabla and 127.0.0.1 but if I change localhost to web server IP
address. The validate check does not fire any more.

Thanks for any help,

Jessica

"Cor Ligthert [MVP]" wrote:
Ian,

If I understand you right, than this is a known bug.

Cor

Nov 21 '05 #3

P: n/a
Jessica,

Make a new question and show some code (with as well the used event). And
paste the code first in a notebook, cut it back and than in the message to
make it readable.

Do not add questions to other ones that makes it difficult to read it back
in the archives.
Cor

"cms123" <cm****@discussions.microsoft.com> schreef in bericht
news:4F**********************************@microsof t.com...
Cor,

I have the other case. Do not know if it is bug also.

I have regularexpress validate on my text box. It works for URL as
localhost/blabla and 127.0.0.1 but if I change localhost to web server IP
address. The validate check does not fire any more.

Thanks for any help,

Jessica

"Cor Ligthert [MVP]" wrote:
Ian,

If I understand you right, than this is a known bug.

Cor

Nov 21 '05 #4

P: n/a
here is my code. It is used in datagrid template column edititem. If there is
no FEIN from database, people need tap it in. Thanks for help.

<td>
<asp:TextBox Width="90" Runat="server" ID="emp_fein" Text='<%#
DataBinder.Eval(Container.DataItem, "FEIN") %>'/></td>
<td>
<asp:RegularExpressionValidator Font-Size="7"
id="Regularexpressionvalidator8" runat="server" ErrorMessage="9 numeric
digital only" ValidationExpression="\d{9}"
ControlToValidate="emp_fein"></asp:RegularExpressionValidator></td>
"Cor Ligthert [MVP]" wrote:
Jessica,

Make a new question and show some code (with as well the used event). And
paste the code first in a notebook, cut it back and than in the message to
make it readable.

Do not add questions to other ones that makes it difficult to read it back
in the archives.
Cor

"cms123" <cm****@discussions.microsoft.com> schreef in bericht
news:4F**********************************@microsof t.com...
Cor,

I have the other case. Do not know if it is bug also.

I have regularexpress validate on my text box. It works for URL as
localhost/blabla and 127.0.0.1 but if I change localhost to web server IP
address. The validate check does not fire any more.

Thanks for any help,

Jessica

"Cor Ligthert [MVP]" wrote:
Ian,

If I understand you right, than this is a known bug.

Cor


Nov 21 '05 #5

P: n/a
Cor,

I have additional found on this. If I use webserver name or domin name, the
validation fires but it does not fire when I use webserver IPaddress.

Is this a bug?

Thanks,

Jessica

"cms123" wrote:
here is my code. It is used in datagrid template column edititem. If there is
no FEIN from database, people need tap it in. Thanks for help.

<td>
<asp:TextBox Width="90" Runat="server" ID="emp_fein" Text='<%#
DataBinder.Eval(Container.DataItem, "FEIN") %>'/></td>
<td>
<asp:RegularExpressionValidator Font-Size="7"
id="Regularexpressionvalidator8" runat="server" ErrorMessage="9 numeric
digital only" ValidationExpression="\d{9}"
ControlToValidate="emp_fein"></asp:RegularExpressionValidator></td>
"Cor Ligthert [MVP]" wrote:
Jessica,

Make a new question and show some code (with as well the used event). And
paste the code first in a notebook, cut it back and than in the message to
make it readable.

Do not add questions to other ones that makes it difficult to read it back
in the archives.
Cor

"cms123" <cm****@discussions.microsoft.com> schreef in bericht
news:4F**********************************@microsof t.com...
Cor,

I have the other case. Do not know if it is bug also.

I have regularexpress validate on my text box. It works for URL as
localhost/blabla and 127.0.0.1 but if I change localhost to web server IP
address. The validate check does not fire any more.

Thanks for any help,

Jessica

"Cor Ligthert [MVP]" wrote:

> Ian,
>
> If I understand you right, than this is a known bug.
>
> Cor
>
>
>


Nov 21 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.