By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,041 Members | 1,046 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,041 IT Pros & Developers. It's quick & easy.

MDI form not closing

P: n/a
I have an MDI application where at some point I can click the close button but nothing happens.
The form is not receiving a closing event.
I have checked the message loop, a WM_CLOSE message is sent to the form, but no event is raised.

Does anyone have an idea why this could happen? This seems to happen in Win2000 only. In WinXP the form always closes although it seems to take
unusually long for the event to be raised.
I'm using VS2002.

Tosch
Nov 21 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Tosch,

Without any code nobody can see something because normally it closes. You
are not the only one that uses VBNet. (And please only a piece not all and
than first pasted in a notebook, cutted back and than pasted in the message)

Just my thought,

Cor

"Tosch" <to**********@swissonline.ch> schreef in bericht
news:b6********************************@4ax.com...
I have an MDI application where at some point I can click the close button
but nothing happens.
The form is not receiving a closing event.
I have checked the message loop, a WM_CLOSE message is sent to the form,
but no event is raised.

Does anyone have an idea why this could happen? This seems to happen in
Win2000 only. In WinXP the form always closes although it seems to take
unusually long for the event to be raised.
I'm using VS2002.

Tosch

Nov 21 '05 #2

P: n/a
I'd love to post some code but my app is fairly big, I'll try to narrow it down.

On Thu, 22 Sep 2005 10:43:36 +0200, "Cor Ligthert [MVP]" <no************@planet.nl> wrote:
Tosch,

Without any code nobody can see something because normally it closes. You
are not the only one that uses VBNet. (And please only a piece not all and
than first pasted in a notebook, cutted back and than pasted in the message)

Just my thought,

Cor

"Tosch" <to**********@swissonline.ch> schreef in bericht
news:b6********************************@4ax.com.. .
I have an MDI application where at some point I can click the close button
but nothing happens.
The form is not receiving a closing event.
I have checked the message loop, a WM_CLOSE message is sent to the form,
but no event is raised.

Does anyone have an idea why this could happen? This seems to happen in
Win2000 only. In WinXP the form always closes although it seems to take
unusually long for the event to be raised.
I'm using VS2002.

Tosch


Nov 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.