By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,418 Members | 1,328 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,418 IT Pros & Developers. It's quick & easy.

Q: double scientific

P: n/a
Hiya

I've just discovered something when writing numbers in scientific notation
in source code. If you write something like

1.83607E-5

Visual Studio changes it to

0.0000183607

Is there a way to stop the Visual Studio environment from doing this?

Thanks

Geoff
Nov 21 '05 #1
Share this Question
Share on Google+
3 Replies

P: n/a
"Geoff Jones" <no********@email.com> wrote in message
news:42***********************@news.dial.pipex.com ...
I've just discovered something when writing numbers in scientific notation
in source code. If you write something like
1.83607E-5
Visual Studio changes it to
0.0000183607

Is there a way to stop the Visual Studio environment from doing this?


/Only/ by turning off all the other clever formatting stuff that VS does
for you, reducing it to a [pretty chunky] text editor.

Or you could try

Val( "1.83607E-5" )

;-))

Regards,
Phill W.
Nov 21 '05 #2

P: n/a
"Geoff Jones" <no********@email.com> schrieb:
I've just discovered something when writing numbers in scientific notation
in source code. If you write something like

1.83607E-5

Visual Studio changes it to

0.0000183607

Is there a way to stop the Visual Studio environment from doing this?


This question has been discussed in this group some weeks ago. The answer
is no -- there is no way to turn off this particular formatting feature
without turning off pretty listing.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://classicvb.org/petition/>

Nov 21 '05 #3

P: n/a
Many thanks guys

Geoff

"Herfried K. Wagner [MVP]" <hi***************@gmx.at> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
"Geoff Jones" <no********@email.com> schrieb:
I've just discovered something when writing numbers in scientific
notation in source code. If you write something like

1.83607E-5

Visual Studio changes it to

0.0000183607

Is there a way to stop the Visual Studio environment from doing this?


This question has been discussed in this group some weeks ago. The answer
is no -- there is no way to turn off this particular formatting feature
without turning off pretty listing.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://classicvb.org/petition/>

Nov 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.