By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,515 Members | 1,042 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,515 IT Pros & Developers. It's quick & easy.

Interface not Registered Error

P: n/a
I've created a .NET application that displays a specified Crystal report. If
I build the application, it runs OK. I want to be able to install this
application (and the appropriate files on other client machines), so
following the document, Crystal Reports 10 and .NET, I added a Setup project
to the solution, added the Primary output, excluded the dependencies
crystalreports10_net_webservicereporting.msm and dotnetfxredist_x86.msm. I
added the CrystalReports10_NET_EmbeddedReporting.msm and entered the
keycode.

When I build the solution (or just the setup proj), I get the below error.
It usually reports a different file each time I try to Rebuild it. Any ideas
on what I'm doing wrong?

E:\Local
Docs\SLambert\TCCA\Crystal\Distribution\ExportAndP rintReport\Setup\Setup.vdp
roj Could not find file
'C:\DOCUME~1\SLambert\LOCALS~1\Temp\VSD28A.tmp\Cry stalReports10_NET_Embedded
Reporting.51C7A60C_AD31_495B_9913_7077386357F0\Pro gram Files\Common
Files\Crystal Decisions\2.5\bin\crdb_ado.dll' 'Interface not registered'
Thanks for your help....

sean
Nov 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a

Resolved the problem by registering Ole32.dll...

http://support.microsoft.com/default...b;en-us;835457
"Sean" <sl*********@yahoo.com> wrote in message
news:um**************@TK2MSFTNGP15.phx.gbl...
I've created a .NET application that displays a specified Crystal report. If I build the application, it runs OK. I want to be able to install this
application (and the appropriate files on other client machines), so
following the document, Crystal Reports 10 and .NET, I added a Setup project to the solution, added the Primary output, excluded the dependencies
crystalreports10_net_webservicereporting.msm and dotnetfxredist_x86.msm. I
added the CrystalReports10_NET_EmbeddedReporting.msm and entered the
keycode.

When I build the solution (or just the setup proj), I get the below error.
It usually reports a different file each time I try to Rebuild it. Any ideas on what I'm doing wrong?

E:\Local
Docs\SLambert\TCCA\Crystal\Distribution\ExportAndP rintReport\Setup\Setup.vdp roj Could not find file
'C:\DOCUME~1\SLambert\LOCALS~1\Temp\VSD28A.tmp\Cry stalReports10_NET_Embedded Reporting.51C7A60C_AD31_495B_9913_7077386357F0\Pro gram Files\Common
Files\Crystal Decisions\2.5\bin\crdb_ado.dll' 'Interface not registered'
Thanks for your help....

sean

Nov 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.