By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,963 Members | 924 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,963 IT Pros & Developers. It's quick & easy.

Dotfuscator and Deployment

P: n/a
OK, I have successfully obfuscated the .exe in my bin folder. When I build
my deployment project, the obfuscated .exe is rebuilt to its original
unobfuscated state. How to I prevent this from happening so that the .msi
file has the obfuscated .exe? Build SetUp Project still insists on
rebuilding the .exe, presumably because it is a dependent of the setup
project.

What switch or setting am I missing?

Thanks,

John

Nov 21 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hi,

Create a new setup wizard project (not added to a project) and add
the obfustated exe to the files to include. The wizard will automatically
detect any dependancies and add them to the project.

Ken
------------------
"John Z" <Jo***@discussions.microsoft.com> wrote in message
news:82**********************************@microsof t.com...
OK, I have successfully obfuscated the .exe in my bin folder. When I build
my deployment project, the obfuscated .exe is rebuilt to its original
unobfuscated state. How to I prevent this from happening so that the .msi
file has the obfuscated .exe? Build SetUp Project still insists on
rebuilding the .exe, presumably because it is a dependent of the setup
project.

What switch or setting am I missing?

Thanks,

John
Nov 21 '05 #2

P: n/a
Thanks, Ken. That should do it!

John

"Ken Tucker [MVP]" wrote:
Hi,

Create a new setup wizard project (not added to a project) and add
the obfustated exe to the files to include. The wizard will automatically
detect any dependancies and add them to the project.

Ken
------------------
"John Z" <Jo***@discussions.microsoft.com> wrote in message
news:82**********************************@microsof t.com...
OK, I have successfully obfuscated the .exe in my bin folder. When I build
my deployment project, the obfuscated .exe is rebuilt to its original
unobfuscated state. How to I prevent this from happening so that the .msi
file has the obfuscated .exe? Build SetUp Project still insists on
rebuilding the .exe, presumably because it is a dependent of the setup
project.

What switch or setting am I missing?

Thanks,

John

Nov 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.