By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,782 Members | 1,154 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,782 IT Pros & Developers. It's quick & easy.

Anchor problems

P: n/a
Hi all,

I have an application where I docked a TabControl with 'FILL'.
In these TabControl I have:
- a Label with anchor 'Left, Top'
- a TextBox with anchor 'Left, Top, Right'
- a Button with anchor 'Top, Right'
All these elements are placed in one row.

On my computer every thing works fine, but if I send
the programm to a friend, then he says the Button does
not appear. What problem can this be for?

Thanks in advance.
Nov 21 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Melanie,

One of the messages about what is probably the problem in this newsgroup.

http://groups.google.com/groups?selm...TNGP10.phx.gbl

It is about all controls.

Cor
Hi all,

I have an application where I docked a TabControl with 'FILL'.
In these TabControl I have:
- a Label with anchor 'Left, Top'
- a TextBox with anchor 'Left, Top, Right'
- a Button with anchor 'Top, Right'
All these elements are placed in one row.

On my computer every thing works fine, but if I send
the programm to a friend, then he says the Button does
not appear. What problem can this be for?

Thanks in advance.

Nov 21 '05 #2

P: n/a
Melanie Rösch schrieb:
I have an application where I docked a TabControl with 'FILL'.
In these TabControl I have:
- a Label with anchor 'Left, Top'
- a TextBox with anchor 'Left, Top, Right'
- a Button with anchor 'Top, Right'
All these elements are placed in one row.

On my computer every thing works fine, but if I send
the programm to a friend, then he says the Button does
not appear. What problem can this be for?


Do the other controls fill the space where the button should be shown or
is there a free space between the other controls? Do both systems use
the same .NET/Windows versions?

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>
Nov 21 '05 #3

P: n/a
> Do the other controls fill the space where the button should be shown or
is there a free space between the other controls? Do both systems use
the same .NET/Windows versions?


The TextBox control fill the space where the button should be shown.
The .Net is the same and the windows is win2000. The only difference
is, that I have service pack 2 and my friend service pack 3.
Nov 21 '05 #4

P: n/a
"Melanie Rösch" <mr*****@rose.de> schrieb:
The TextBox control fill the space where the button should
be shown. The .Net is the same and the windows is win2000.
The only difference is, that I have service pack 2 and my friend
service pack 3.


That's really weird. You can add test code to loop through the 'Controls'
collection of the container that contains the button in order to see if the
button has been added correctly to this collection.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://dotnet.mvps.org/dotnet/faqs/>

Nov 21 '05 #5

P: n/a


Herfried K. Wagner [MVP] schrieb:
"Melanie Rösch" <mr*****@rose.de> schrieb:
The TextBox control fill the space where the button should
be shown. The .Net is the same and the windows is win2000.
The only difference is, that I have service pack 2 and my friend
service pack 3.

That's really weird. You can add test code to loop through the
'Controls' collection of the container that contains the button in order
to see if the button has been added correctly to this collection.


Hi Herfried,

now I have tried to put all the things in a seperate panel.
That means the label docked right in the panel, the textfield docked
fill and an empty label for space and the button docked right. But
the problem is the same. I get the button but my friend not.

How can I see that the button has been added correctly to the collection
of the label? I also can send you a screenshot of both scenarios, if you
want.

Thanks Melanie
Nov 21 '05 #6

P: n/a
"Melanie Rösch" <mr*****@rose.de> schrieb:
now I have tried to put all the things in a seperate panel.
That means the label docked right in the panel, the textfield docked
fill and an empty label for space and the button docked right. But
the problem is the same. I get the button but my friend not.

How can I see that the button has been added correctly to the collection
of the label? I also can send you a screenshot of both scenarios, if you
want.


You can send me screenshots (GIF format preferred) and/or a small sample
application that can be used to repro the problem, if you want. My email
address can be found at <URL:http://dotnet.mvps.org/meta/author/#Contact>.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://dotnet.mvps.org/dotnet/faqs/>

Nov 21 '05 #7

P: n/a
Melanie,

Did you look at my message too?

Cor

"Melanie Rösch" <mr*****@rose.de>



Herfried K. Wagner [MVP] schrieb:
"Melanie Rösch" <mr*****@rose.de> schrieb:
The TextBox control fill the space where the button should
be shown. The .Net is the same and the windows is win2000.
The only difference is, that I have service pack 2 and my friend
service pack 3.

That's really weird. You can add test code to loop through the
'Controls' collection of the container that contains the button in order
to see if the button has been added correctly to this collection.


Hi Herfried,

now I have tried to put all the things in a seperate panel.
That means the label docked right in the panel, the textfield docked
fill and an empty label for space and the button docked right. But
the problem is the same. I get the button but my friend not.

How can I see that the button has been added correctly to the collection
of the label? I also can send you a screenshot of both scenarios, if you
want.

Thanks Melanie

Nov 21 '05 #8

P: n/a
Update:
You can send me screenshots (GIF format preferred) and/or a small sample
application that can be used to repro the problem, if you want. My email
address can be found at <URL:http://dotnet.mvps.org/meta/author/#Contact>.


OK, I received the screenshots and replied by mail in German. If there are
any news on this topic, please post them to this thread.

--
M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://dotnet.mvps.org/dotnet/faqs/>

Nov 21 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.