By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,504 Members | 1,194 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,504 IT Pros & Developers. It's quick & easy.

Thumbnail Problems

P: n/a
I am trying to make a listview that i will be using to display a group of
pictures in a form. For some reason though the pictures come up horribly. I
have a function that takes a image and returns a thumbnail of it why are they
working so bad? Also it works very slow how to make this quicker?

Thanks

WStoreyII
Nov 21 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
WStorey

There can be a lot of reasons, the starting images and/or your process.

Did you when making the program first use a picturebox to look how the
images looks after making thumbnails.

I get the idea as well that you did not save the thumbnails somewhere
however converts them on the fly from images. I can imagen that that takes a
lot of time.

Just some thoughts,

Cor

"WStoreyII"
..
I am trying to make a listview that i will be using to display a group of
pictures in a form. For some reason though the pictures come up horribly.
I
have a function that takes a image and returns a thumbnail of it why are
they
working so bad? Also it works very slow how to make this quicker?

Thanks

WStoreyII

Nov 21 '05 #2

P: n/a
WStorey

There can be a lot of reasons, the starting images and/or your process.

Did you when making the program first use a picturebox to look how the
images looks after making thumbnails.

I get the idea as well that you did not save the thumbnails somewhere
however converts them on the fly from images. I can imagen that that takes a
lot of time.

Just some thoughts,

Cor

"WStoreyII"
..
I am trying to make a listview that i will be using to display a group of
pictures in a form. For some reason though the pictures come up horribly.
I
have a function that takes a image and returns a thumbnail of it why are
they
working so bad? Also it works very slow how to make this quicker?

Thanks

WStoreyII

Nov 21 '05 #3

P: n/a
"WStoreyII" <WS*******@discussions.microsoft.com> schrieb:
I am trying to make a listview that i will be using to display a group of
pictures in a form. For some reason though the pictures come up horribly.
I
have a function that takes a image and returns a thumbnail of it why are
they
working so bad?


If you are calling the image's 'GetThumbnailImage' method, an embedded
thumbnail will be used if the image contains one. These thumbnails often
have a bad quality. Instead of using this method, you can create the
thumbnails yourself:

Resizing an image with a certain interpolation mode
<URL:http://dotnet.mvps.org/dotnet/faqs/?id=interpolationmode&lang=en>

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>

Nov 21 '05 #4

P: n/a
"WStoreyII" <WS*******@discussions.microsoft.com> schrieb:
I am trying to make a listview that i will be using to display a group of
pictures in a form. For some reason though the pictures come up horribly.
I
have a function that takes a image and returns a thumbnail of it why are
they
working so bad?


If you are calling the image's 'GetThumbnailImage' method, an embedded
thumbnail will be used if the image contains one. These thumbnails often
have a bad quality. Instead of using this method, you can create the
thumbnails yourself:

Resizing an image with a certain interpolation mode
<URL:http://dotnet.mvps.org/dotnet/faqs/?id=interpolationmode&lang=en>

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>

Nov 21 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.