By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,972 Members | 1,223 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,972 IT Pros & Developers. It's quick & easy.

Keyboard shortcuts....

P: n/a
Sorry, this could be a newby question... but how do we do the keyboard
shortcuts in .NET

buttonname.text = "&Click Me"

Does not give the short cut Alt-C for the button.

Helene
Nov 21 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Ok... looks like the shortcuts are not displayed until someone press the Alt
key for the first time....
How can I force them to be displayed?

Thanks for your help,

Helene

"Helene Day" <noSpam@noSpam> wrote in message
news:u$**************@TK2MSFTNGP10.phx.gbl...
Sorry, this could be a newby question... but how do we do the keyboard
shortcuts in .NET

buttonname.text = "&Click Me"

Does not give the short cut Alt-C for the button.

Helene

Nov 21 '05 #2

P: n/a
Helene Day wrote:
Ok... looks like the shortcuts are not displayed until someone press the Alt
key for the first time....
How can I force them to be displayed?

Thanks for your help,

Helene


This is a "feature" of any OS >= Win2k. It's a control panel display
applet option... check any of these old posts for a "cure". This'll only
effect your PC... The end user will be responsible for their own setting.

Results 1 - 49 of about 112 for "alt-key "hide navigation"" -dotnet
group:*.vb.*. (2.06 seconds)
http://groups.google.com/groups?as_e...&num=100&hl=en

--
Ken Halter - MS-MVP-VB - http://www.vbsight.com
Please keep all discussions in the groups..
Nov 21 '05 #3

P: n/a
Many thanks for the info Ken.

Here is my fix for now:

Private Sub MyForm_Activated(ByVal sender As Object, ByVal e As
System.EventArgs) Handles MyBase.Activated
' Kludge to enable the shortcuts... since I am not using Alt-Z ....

System.Windows.Forms.SendKeys.Send("%z")

End Sub

"Ken Halter" <Ken_Halter@Use_Sparingly_Hotmail.com> wrote in message
news:ey**************@TK2MSFTNGP15.phx.gbl...
Helene Day wrote:
Ok... looks like the shortcuts are not displayed until someone press the Alt key for the first time....
How can I force them to be displayed?

Thanks for your help,

Helene
This is a "feature" of any OS >= Win2k. It's a control panel display
applet option... check any of these old posts for a "cure". This'll only
effect your PC... The end user will be responsible for their own setting.

Results 1 - 49 of about 112 for "alt-key "hide navigation"" -dotnet
group:*.vb.*. (2.06 seconds)

http://groups.google.com/groups?as_e...&num=100&hl=en
--
Ken Halter - MS-MVP-VB - http://www.vbsight.com
Please keep all discussions in the groups..

Nov 21 '05 #4

P: n/a
Helene Day wrote:
Here is my fix for now: [...] ' Kludge to enable the shortcuts... since I am not using Alt-Z


Presumably if the user has selected not to see the shortcut accelerators
until they press Alt, this is because they don't want to see the shortcut
accelerators until they press Alt. I accept that this is the default setting
and agree that it's a crappy feature, but it is a user preference and they
can change it if they don't like it. Forcing your preference on the user
could be considered a bit rude...

Can't you just follow the default behaviour and allow the user to control
whether the accelerators are displayed or not?

--

(O)enone
Nov 21 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.