By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,572 Members | 1,516 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,572 IT Pros & Developers. It's quick & easy.

VB.NET/Crystal - How do I change a report's connection "integrated security" to FALSE?

P: n/a
I am writing a Windows forms VB.Net/MS SQL application via VS 2003 that
utilizes Crystal Reports. I want to be able to dynamically set the
report data source at run time.

I'm trying to change the the reports "integrated security" from TRUE to
FALSE via the "Set Location" dialog in the report designer with no
success. It is not intuitive (at least not to me.)

I get the following error:

"Error in file....Invalid table number."

The error is being generated at this line of my code:

'DatabaseName is changing at runtime, specify the table location.
CrTable.Location = "UpsizeUATSQLBackup.dbo." &
CrTable.Location.Substring(CrTable.Location.LastIn dexOf(".") + 1)

If I change "UpsizeUATSQLBackup.dbo." to the original db location i.e.
"UpsizeUATSQL.dbo" it works fine.

I've seen other posts on the web that state that the "integrated
security" for the report connection has to be FALSE, otherwise the
connection is hard coded into the report.

Article c2011430 on CR support site seems to indicate that you can
change it in Crystal 9, where previously you could not, due to a bug.

My question is how do I change the report's connection "integrated
security" to FALSE?

Tks for any guidance/help you can provide.

....Henry
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 20 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Henry <an*******@devdex.com> wrote in news:eXRfCpbdEHA.2384
@TK2MSFTNGP09.phx.gbl:
I am writing a Windows forms VB.Net/MS SQL application via VS 2003 that
utilizes Crystal Reports. I want to be able to dynamically set the
report data source at run time.


Why don't you pass a dataset instead?

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.
http://members.ebay.com/aboutme/coolspot18/
Nov 20 '05 #2

P: n/a
Hi Henry,

Sorry; I was out all evening and just saw your post.

I am changing mine in crystal 10.0, however it should also work in cr 9.

Go to set location; then select 'new connection'; connect via ole db; when
it asks for a pwd and login, enter the appropriate sql server login; check
or uncheck for integrated security, etc. Once finished, you should check
properties and it should show the connection as integrated security false.

HTH,

Bernie Yaeger

"Henry" <an*******@devdex.com> wrote in message
news:eX**************@TK2MSFTNGP09.phx.gbl...
I am writing a Windows forms VB.Net/MS SQL application via VS 2003 that
utilizes Crystal Reports. I want to be able to dynamically set the
report data source at run time.

I'm trying to change the the reports "integrated security" from TRUE to
FALSE via the "Set Location" dialog in the report designer with no
success. It is not intuitive (at least not to me.)

I get the following error:

"Error in file....Invalid table number."

The error is being generated at this line of my code:

'DatabaseName is changing at runtime, specify the table location.
CrTable.Location = "UpsizeUATSQLBackup.dbo." &
CrTable.Location.Substring(CrTable.Location.LastIn dexOf(".") + 1)

If I change "UpsizeUATSQLBackup.dbo." to the original db location i.e.
"UpsizeUATSQL.dbo" it works fine.

I've seen other posts on the web that state that the "integrated
security" for the report connection has to be FALSE, otherwise the
connection is hard coded into the report.

Article c2011430 on CR support site seems to indicate that you can
change it in Crystal 9, where previously you could not, due to a bug.

My question is how do I change the report's connection "integrated
security" to FALSE?

Tks for any guidance/help you can provide.

...Henry
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

Nov 20 '05 #3

P: n/a
I was able to change "integrated security" to FALSE by pausing mySQL Server & then, in the report designer, I right click on theFieldExplorer/DatabaseFields and select 'Verify Database' fromthe menu. Since it can't find the database, it prompts for theconnection info. Start-up SQL server again & then fill out theconnection info (with integrated security unchecked). Then saveyour report.

:>kris
I am writing a Windows forms VB.Net/MS SQL application via VS2003 that
utilizes Crystal Reports. I want to be able to dynamically setthe
report data source at run time.

I'm trying to change the the reports "integrated security" fromTRUE to
FALSE via the "Set Location" dialog in the report designer withno
success. It is not intuitive (at least not to me.)

I get the following error:

"Error in file....Invalid table number."

The error is being generated at this line of my code:

'DatabaseName is changing at runtime, specify the tablelocation.
CrTable.Location = "UpsizeUATSQLBackup.dbo." &
CrTable.Location.Substring(CrTable.Location.LastIn dexOf(".") +1)

If I change "UpsizeUATSQLBackup.dbo." to the original dblocation i.e.
"UpsizeUATSQL.dbo" it works fine.

I've seen other posts on the web that state that the"integrated
security" for the report connection has to be FALSE, otherwisethe
connection is hard coded into the report.

Article c2011430 on CR support site seems to indicate that youcan
change it in Crystal 9, where previously you could not, due toa bug.

My question is how do I change the report's connection"integrated
security" to FALSE?

Tks for any guidance/help you can provide.

....Henry
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

User submitted from AEWNET (http://www.aewnet.com/)
Nov 21 '05 #4

P: n/a
Hi,

ON Crystal 10 (perhaps 9 as well):
1. go to 'set database location'
2. in the top, open the name of the server and properties until you see the
tables
3. on the bottom, click 'history'
4. select the server name in the bottom
5. you will now see a connection info request
6. fill out the request and enter user id and pwd; uncheck 'use integrated
security'
7. click next
8. click finish
9. now select the table to replace the table above - same name
10. click the 'update' button

You're done. I had to do this to over 150 reports some time ago. It's a
bit buggy, so after you save, reopen the report to verify that the change
'took'.

HTH,

Bernie Yaeger
"Guest" <Guest@aew_nospam.com> wrote in message
news:Op**************@TK2MSFTNGP14.phx.gbl...
I was able to change "integrated security" to FALSE by pausing my SQL Server
& then, in the report designer, I right click on the
FieldExplorer/DatabaseFields and select 'Verify Database' from the menu.
Since it can't find the database, it prompts for the connection info.
Start-up SQL server again & then fill out the connection info (with
integrated security unchecked). Then save your report.

:>kris
I am writing a Windows forms VB.Net/MS SQL application via VS 2003 that
utilizes Crystal Reports. I want to be able to dynamically set the
report data source at run time.

I'm trying to change the the reports "integrated security" from TRUE to
FALSE via the "Set Location" dialog in the report designer with no
success. It is not intuitive (at least not to me.)

I get the following error:

"Error in file....Invalid table number."

The error is being generated at this line of my code:

'DatabaseName is changing at runtime, specify the table location.
CrTable.Location = "UpsizeUATSQLBackup.dbo." &
CrTable.Location.Substring(CrTable.Location.LastIn dexOf(".") + 1)

If I change "UpsizeUATSQLBackup.dbo." to the original db location i.e.
"UpsizeUATSQL.dbo" it works fine.

I've seen other posts on the web that state that the "integrated
security" for the report connection has to be FALSE, otherwise the
connection is hard coded into the report.

Article c2011430 on CR support site seems to indicate that you can
change it in Crystal 9, where previously you could not, due to a bug.

My question is how do I change the report's connection "integrated
security" to FALSE?

Tks for any guidance/help you can provide.

....Henry
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

User submitted from AEWNET (http://www.aewnet.com/)
Nov 21 '05 #5

P: n/a
Bernie,

At least I succeeded in finding a solution for a progressbar with the fill
of the datatable.

Interested or did you found it yourself already

I used an access database to get it slow, however it is terrible slow.

Cor
Nov 21 '05 #6

P: n/a
Hi Cor,

Thanks, but yes, I already got it working - thanks, as always.

Bernie

"Cor Ligthert" <no************@planet.nl> wrote in message
news:eB**************@TK2MSFTNGP15.phx.gbl...
Bernie,

At least I succeeded in finding a solution for a progressbar with the fill
of the datatable.

Interested or did you found it yourself already

I used an access database to get it slow, however it is terrible slow.

Cor

Nov 21 '05 #7

P: n/a
Did you post how you did it and if so what was the thread name?

If not, will you please? :)

"Bernie Yaeger" <be*****@cherwellinc.com> wrote in message
news:be*****@cherwellinc.com:
Hi Cor,

Thanks, but yes, I already got it working - thanks, as always.

Bernie

"Cor Ligthert" <no************@planet.nl> wrote in message
news:eB**************@TK2MSFTNGP15.phx.gbl...
Bernie,

At least I succeeded in finding a solution for a progressbar with the
fill
of the datatable.

Interested or did you found it yourself already

I used an access database to get it slow, however it is terrible slow.

Cor


Nov 21 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.