By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,641 Members | 1,446 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,641 IT Pros & Developers. It's quick & easy.

A bit desparate: WinForms in IE - Security Help and HDC error

P: n/a
Hello,

Sorry for the cross posts - I'm need of help...

I am trying to deploy a very simple webform with the following features:
-DataGrid (not yet bound)
-Textboxes
-Labels
-Combo Box
-Tab Control

I'm having 2 problems with Winforms in IE.

1. Sometimes my Winforms is giving a System.ArgumentException HDC error
when it is loading up. It seems to happen when I load a winform control
a second time after leaving the page for a while.

To fix the issue, I need to shut down IE via the task manager and then
restart IE. This clear the HDC issue for a while.

2. Is it possible to run a .NET 1.1 Winform in IE control without giving
Full Trust to a site? I can't seem to get the example from MSDN working:

http://msdn.microsoft.com/library/de...l=/library/en-
us/dnforms/html/winforms11122002.asp

I gave Execution privileges to the site and Full Trust to the strong
named assembly, but it doesn't work. The only way I can get the assembly
to run in the Internet zone is to give Full Trust to http://127.0.0.1.
The privileges I give to the Strong Named Assembly doesn't seem to make
any difference.

Any help would be appreciated!

--
Lucas Tam (RE********@rogers.com)
Please delete "REMOVE" from the e-mail address when replying.
http://members.ebay.com/aboutme/coolspot18/
Nov 20 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.