By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,975 Members | 1,172 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,975 IT Pros & Developers. It's quick & easy.

Form Icon

P: n/a
I am new to the .Net but not new to VB, but I am having problems with the
form icon. I made an icon file using VS.Net 2003 and then added it to my
form. The icon shows in the properties, but not on the form. If I use an
old icon it works fine. Is there something that Ishould know about this?

TIA
Nov 20 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Project Properties -> Build

Set the Application Icon to your custom icon.
--
Klaus H. Probst, MVP
http://www.vbbox.com/
"Lespaul36" <le*******@none.net> wrote in message
news:uf**************@TK2MSFTNGP12.phx.gbl...
I am new to the .Net but not new to VB, but I am having problems with the
form icon. I made an icon file using VS.Net 2003 and then added it to my
form. The icon shows in the properties, but not on the form. If I use an
old icon it works fine. Is there something that Ishould know about this?

TIA

Nov 20 '05 #2

P: n/a
* "Lespaul36" <le*******@none.net> scripsit:
I am new to the .Net but not new to VB, but I am having problems with the
form icon. I made an icon file using VS.Net 2003 and then added it to my
form. The icon shows in the properties, but not on the form. If I use an
old icon it works fine. Is there something that Ishould know about this?


So, the icon doesn't show up in the title bar or in the Alt+Tab dialog?

What icon types did you add to your icon file (size, color depth)?

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>
Nov 20 '05 #3

P: n/a
I wasn't getting an icon in either. I reduced the depth and now I have it
on my form. But, I don't have it in the Alt+Tab.

I have 3 copies of the icon
32x32 at 16
32x32 at 256
16x16 at 16

Thanks.
"Herfried K. Wagner [MVP]" <hi***************@gmx.at> wrote in message
news:OX**************@TK2MSFTNGP09.phx.gbl...
* "Lespaul36" <le*******@none.net> scripsit:
I am new to the .Net but not new to VB, but I am having problems with the form icon. I made an icon file using VS.Net 2003 and then added it to my form. The icon shows in the properties, but not on the form. If I use an old icon it works fine. Is there something that Ishould know about
this?
So, the icon doesn't show up in the title bar or in the Alt+Tab dialog?

What icon types did you add to your icon file (size, color depth)?

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>

Nov 20 '05 #4

P: n/a
* "Lespaul36" <le*******@none.net> scripsit:
I wasn't getting an icon in either. I reduced the depth and now I have it
on my form. But, I don't have it in the Alt+Tab.

I have 3 copies of the icon
32x32 at 16
32x32 at 256
16x16 at 16


That should be OK. Maybe it's the order in which the icons have been
added to the file that causes the problem, but I am not sure about that.

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>
Nov 20 '05 #5

P: n/a
Well, I deleted the icons and redid them as 32x32 at 16 and 16x16 at 16. Now
it works fine.
Thanks.
"Herfried K. Wagner [MVP]" <hi***************@gmx.at> wrote in message
news:%2****************@TK2MSFTNGP11.phx.gbl...
* "Lespaul36" <le*******@none.net> scripsit:
I wasn't getting an icon in either. I reduced the depth and now I have it on my form. But, I don't have it in the Alt+Tab.

I have 3 copies of the icon
32x32 at 16
32x32 at 256
16x16 at 16


That should be OK. Maybe it's the order in which the icons have been
added to the file that causes the problem, but I am not sure about that.

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>

Nov 20 '05 #6

P: n/a
* "Lespaul36" <le*******@none.net> scripsit:
Well, I deleted the icons and redid them as 32x32 at 16 and 16x16 at 16. Now
it works fine.


Thank you for confirming that.

--
Herfried K. Wagner [MVP]
<URL:http://dotnet.mvps.org/>
Nov 20 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.