469,926 Members | 1,492 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,926 developers. It's quick & easy.

<customErrors mode="Off"/> troubles

Hey All,

I'm developing a new website and I want the customer to be able to se my
work in progress so I have set up a server behind my ADSL-router. The server
is using W2003.

I've created a new website and uploaded some files to test the site.
Anonymous access isn't allowed. After I've logged on to the site I see this
message:
Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

But I don't get this, because this is my web.config file:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<compilation defaultLanguage="vb" debug="true" />

<customErrors mode="Off"/>

<authentication mode="Windows" />

<authorization>
<allow users="*" /> <!-- Allow all users -->
</authorization>

<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>
</configuration>

What am I missing here?

Thanks!
Nov 20 '05 #1
1 4595
Any syntax error in your web.config will cause that sort of message.

HTH,
Greg

"Menno Abbink" <no*@inuse.com> wrote in message
news:40***********************@news.xs4all.nl...
Hey All,

I'm developing a new website and I want the customer to be able to se my
work in progress so I have set up a server behind my ADSL-router. The
server
is using W2003.

I've created a new website and uploaded some files to test the site.
Anonymous access isn't allowed. After I've logged on to the site I see
this
message:
Server Error in '/' Application.
----------------------------------------------------------------------------
----

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could,
however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable
on remote machines, please create a <customErrors> tag within a
"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

But I don't get this, because this is my web.config file:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<compilation defaultLanguage="vb" debug="true" />

<customErrors mode="Off"/>

<authentication mode="Windows" />

<authorization>
<allow users="*" /> <!-- Allow all users -->
</authorization>

<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>
</configuration>

What am I missing here?

Thanks!

Nov 20 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Han | last post: by
1 post views Thread by Savas Ates | last post: by
5 posts views Thread by Savas Ates | last post: by
2 posts views Thread by Beemer Biker | last post: by
3 posts views Thread by =?Utf-8?B?bmt3?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.