By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,203 Members | 1,365 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,203 IT Pros & Developers. It's quick & easy.

Visual Studio Remote Debugging:

P: n/a
I cannot for the life of me get remove debugging to work. I continue to
receive "Error while trying to run project: Unable to start debugging on the
web server. Access is denied. Verify that you are an administrator or
member of the Debugger Users".

I have followed
(ms-help://MS.VSCC.2003/MS.MSDNQTR.2003FEB.1033/vsdebug/html/vxtbsHTTPServer
Errors.htm). I have seen
(http://www.dotnet247.com/247referenc...dotnet.com/tea
m/csharp/learn/whitepapers/howtosolvedebuggerproblems.doc) and followed. I
have checked and double checked that my XP user/pass is on the 2k server and
user is a member of both administrators and Debugger Users. Without a doubt
the user is working correctly because I can put in the ole \\server\admin$
from the XP box and never get prompted for any information. I have removed
Remote components, .NET framework, IIS and reinstalled in reverse order. I
have tried to manually attach to the asp.net process using "tools->Debug
processes" from visual studio.

What am I missing here?
Nov 20 '05 #1
Share this Question
Share on Google+
14 Replies


P: n/a
Hi,

Based on my understanding, you have checked the following things.
1. The logon username/password has been a member of the Remote machine's
adminitrators and Debugger Users.
2. The IIS has enabled windows integrated authentication, to simplied the
problem, please disable the other authentication modes(e.g. anonymous,
basic ...)

Now please make some tests.
1. Please create a new web application on the remote machine by inputting
the URL in the Location section.
http://remotingservername/TestWebApp
2. Press F5 to debugging the TestWebApp on the remoting machine.
3. Press Ctrl+F5 to see if we can access to the
http://remotingservername/TestWebApp and the webapplication you referred to
in your post.

From your description, you have tried to manually attach to the remoting
process, did that work for you, if no, what is the error message you are
getting.

Please perform the test and let me know the result.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #2

P: n/a
Thanks peter,

See Inline:

""Peter Huang"" <v-******@online.microsoft.com> wrote in message
news:Sg**************@cpmsftngxa06.phx.gbl...
Hi,

Based on my understanding, you have checked the following things.
1. The logon username/password has been a member of the Remote machine's
adminitrators and Debugger Users.
This has been checked and confirmed.
2. The IIS has enabled windows integrated authentication, to simplied the
problem, please disable the other authentication modes(e.g. anonymous,
basic ...)

Done.
Now please make some tests.
1. Please create a new web application on the remote machine by inputting
the URL in the Location section.
http://remotingservername/TestWebApp
2. Press F5 to debugging the TestWebApp on the remoting machine.
3. Press Ctrl+F5 to see if we can access to the
http://remotingservername/TestWebApp and the webapplication you referred to in your post.

Same error as before. The error goes like this:
"Error while trying to run project: Unable to start debugging on the web
server. Access is denied. Verify that you are an administrator or a member
of the 'Debugger Users' group on the machine you are trying to debug. After
being added to the 'Debugger Users' group, you must log off and log back on
for the setting to apply."
From your description, you have tried to manually attach to the remoting
process, did that work for you, if no, what is the error message you are
getting.

Using "Default" mode for transport I receive the error:
"Unable to connect to the machine 'devbox'. Access is denied. Verify that
you are an administrator or a member of the 'Debugger Users' group on the
machine you are trying to debug. After being added to the 'Debugger Users'
group, you must log off and log back on for the setting to apply."

Changing from default to "Pipe" or "TCP/IP" gives me:
"Unable to connect to 'DEVBOX'. MSVCMON is either not running on the remote
machine or is running in tcp/ip mode."

Manually start "MSVCMON" and connecting gives me:
"Unable to connect to 'DEVBOX'. Access is denied.
Please perform the test and let me know the result.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.


Again Thanks,
Nov 20 '05 #3

P: n/a
Hi,

From you understanding, now you can create a new webapp on the remote
machine and you can use Ctrl+F5 to browse the webapp.
But you can not use the F5 or manually attach to the remoting
webapplication. If I have any misunderstanding, please feel free to let me
know.

I think now we can try to check the following steps.
1. We use the same username/password on both the local machine and remote
machine and they are all in the Administrators group.
2. Check the "Machine Debug Manager" service's permission setting by
following the steps below.
2.1 Run DComCnfg to invoke the DCOM Setting dialog, drill through to
"Machine Debug Manager" in the DCOM Config
2.2 Right click on the "Machine Debug Manager" and select properties
2.3 Check the Security Tab to see if the user account used to logon and
debugging has the right permission, please check all the three sections.
2.4 Check the Identity to see if it runs at the "the system account"

3. Run the secpol.msc to enable the Logon Event audit in case you have not
done it.
3.1 Drill through the Security setting/Local policies/Audit policy
3.2 Check the Success and Failure for the Audit Logon Event

4. Try to do the remoting debugging again and then check the eventlog's
security section on the remote machine to see if there is any Failed event.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #4

P: n/a
No your first part is incorrect. I cannot use ctrl+F5 to debug. Neither
ctrl+F5 or pushing the run button starts debugging. Both ways give the same
error message.

"Error while trying to run project: Unable to start debugging on the web
server. Access is denied. Verify that you are an administrator or a member
of the 'Debugger Users' group on the machine you are trying to debug. After
being added to the 'Debugger Users' group, you must log off and log back on
for the setting to apply."

I checked the settings in "Machine Debug Manager" and the only one that
required changing was the Identity->"the system account". As for "security
settings", it was already running but does not get any failures or signs of
attempted logins. I also tried adding both "everyone" and enabling and
adding "guest" to the "debugging users" account and still receive the same
error. I can connect to \\server\wwwroot$\ without a hitch. I can log on
locally to the server using the same credentials and get on the system as an
administrator.

""Peter Huang"" <v-******@online.microsoft.com> wrote in message
news:OJ****************@cpmsftngxa06.phx.gbl...
Hi,

From you understanding, now you can create a new webapp on the remote
machine and you can use Ctrl+F5 to browse the webapp.
But you can not use the F5 or manually attach to the remoting
webapplication. If I have any misunderstanding, please feel free to let me
know.

I think now we can try to check the following steps.
1. We use the same username/password on both the local machine and remote
machine and they are all in the Administrators group.
2. Check the "Machine Debug Manager" service's permission setting by
following the steps below.
2.1 Run DComCnfg to invoke the DCOM Setting dialog, drill through to
"Machine Debug Manager" in the DCOM Config
2.2 Right click on the "Machine Debug Manager" and select properties
2.3 Check the Security Tab to see if the user account used to logon and
debugging has the right permission, please check all the three sections.
2.4 Check the Identity to see if it runs at the "the system account"

3. Run the secpol.msc to enable the Logon Event audit in case you have not
done it.
3.1 Drill through the Security setting/Local policies/Audit policy
3.2 Check the Success and Failure for the Audit Logon Event

4. Try to do the remoting debugging again and then check the eventlog's
security section on the remote machine to see if there is any Failed event.
Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #5

P: n/a
Hi,

Ctrl+ F5 equals to pressing Debug/Start Without Debugging Ctrl+F5 menu.
So running the project in this approach is similar with we navigate the
webapplication remotely.
Now you may try to make a test.
Assuming we want to debug the remote application
http://remoteserver/webapp/webform1.aspx, then we can open the IE and then
navigate the http://remoteserver/webapp/webform1.aspx to see if the problem
persists.
[NOTE, please specified the remote server IIS setting with windows
authentication ONLY]

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #6

P: n/a
Ctrl + F5 compiles the project and opens a IE browser to the page. No
errors, page displays as expected. Breakpoints are not followed. No
debugging is being done. Im not following what you were wanting from this
test. This server will run a asp.net app without a hitch as long as you
don't try to remotely debug the app. Also as noted the server is setup with
only "Integrated Windows Authentication" checked. Server does NOT prompt
for information when the page loads.

Bryan
""Peter Huang"" <v-******@online.microsoft.com> wrote in message
news:2H**************@cpmsftngxa06.phx.gbl...
Hi,

Ctrl+ F5 equals to pressing Debug/Start Without Debugging Ctrl+F5 menu.
So running the project in this approach is similar with we navigate the
webapplication remotely.
Now you may try to make a test.
Assuming we want to debug the remote application
http://remoteserver/webapp/webform1.aspx, then we can open the IE and then
navigate the http://remoteserver/webapp/webform1.aspx to see if the problem persists.
[NOTE, please specified the remote server IIS setting with windows
authentication ONLY]

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #7

P: n/a
Hi Bryan,

To further troubleshoot the problem, I think we may need to enable the
EventLog, so that we will know what has happened.

On the Start menu, select Programs , select Administrative Tools , and then
select Local Security Policy .
On the left-hand pane, you see a tree view. Click the plus (+) sign at the
left of the Local Policies , and you see the Audit Policy entry. Select the
Audit Policy entry, and note that the right pane contains all audit
options, which one is enabled and which one is not. Right-clicking at any
of these options allows you to enable or disable them.
Enable auditing for success and failure for the following options: Audit
logon events, Audit object access, Audit privilege use.
Close the Local Security Policy window.

Once you have activated these logging options, test your client again.
After you get the error message, use Event Viewer to see if there are any
events. The event may tell you why access was denied. Also, it can tell you
who is logged on to the client computer and if this is a domain user or a
local user. It can tell you that the protocol requested by the client is
not available on the server, and so forth.

Also please enable the Audit account logon events too by repeated the steps
above.

If I use Ctrl+F5 to run the Webapplication, I will see the account logon to
the machine on the remote machine's eventlog.
Also when you press Ctrl+Alt+P to open the attach dialog and set the
Transport to default(the other two are for native code only), and set the
name to the remote machine's name, and then click refresh, can you see the
processed on the remote machine in the Available Processes?

And to isolate the problem, I think you may try to remote debugging another
remote machine to see if the problem persists.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #8

P: n/a
So we are clear, at this point I have "anonymous allowed" unchecked under
"directory security" in the IIS control panel. I have did the below
settings to "local security policy". Starting the startpage using Ctrl+F5
causes a prompt for username/password which I use the same that I login
with, this causes numerous events such as 576, 680, and 540's all successful
either from the "SYSTEM" account or from my username account.. Loading the
project and starting using F5 still shows the same error and does not
produce any events on the developer server. Attempting to debug using the
"Tools->Debug processes" or Ctrl+Alt+P gives the same error and no events.
""Peter Huang"" <v-******@online.microsoft.com> wrote in message
news:Tz**************@cpmsftngxa06.phx.gbl...
Hi Bryan,

To further troubleshoot the problem, I think we may need to enable the
EventLog, so that we will know what has happened.

On the Start menu, select Programs , select Administrative Tools , and then select Local Security Policy .
On the left-hand pane, you see a tree view. Click the plus (+) sign at the
left of the Local Policies , and you see the Audit Policy entry. Select the Audit Policy entry, and note that the right pane contains all audit
options, which one is enabled and which one is not. Right-clicking at any
of these options allows you to enable or disable them.
Enable auditing for success and failure for the following options: Audit
logon events, Audit object access, Audit privilege use.
Close the Local Security Policy window.

Once you have activated these logging options, test your client again.
After you get the error message, use Event Viewer to see if there are any
events. The event may tell you why access was denied. Also, it can tell you who is logged on to the client computer and if this is a domain user or a
local user. It can tell you that the protocol requested by the client is
not available on the server, and so forth.

Also please enable the Audit account logon events too by repeated the steps above.

If I use Ctrl+F5 to run the Webapplication, I will see the account logon to the machine on the remote machine's eventlog.
Also when you press Ctrl+Alt+P to open the attach dialog and set the
Transport to default(the other two are for native code only), and set the
name to the remote machine's name, and then click refresh, can you see the
processed on the remote machine in the Available Processes?

And to isolate the problem, I think you may try to remote debugging another remote machine to see if the problem persists.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #9

P: n/a
Hi,

The problem is very strange, to isolate the problem, can you try to do the
remote debugging on another machine to see if the problem persists.
i.e. on another machine with VS.NET 2003 installed and try to remote
debugging from the current machine to see if the problem persists.

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #10

P: n/a
Hi,

Another suggestion is that you may try to use the filemon and regmon on
both machines to see if there is any access denied with files or registry.
You may get the two tools in the links below.
FileMon
http://www.sysinternals.com/ntw2k/source/filemon.shtml
Regmon
http://www.sysinternals.com/ntw2k/source/regmon.shtml

Also is there any proxy or firewall between the two servers?

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #11

P: n/a
Hi,

Another suggestion is that you may try to use the filemon and regmon on
both machines to see if there is any access denied with files or registry.
You may get the two tools in the links below.
FileMon
http://www.sysinternals.com/ntw2k/source/filemon.shtml
Regmon
http://www.sysinternals.com/ntw2k/source/regmon.shtml

Also is there any proxy or firewall between the two servers?

You may also try to check the link below.
Error: Unable to Start Debugging on the Web Server
http://msdn.microsoft.com/library/de...us/vsdebug/htm
l/vxtbshttpservererrors.asp

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.
Nov 20 '05 #12

P: n/a
Hi,

As for the IE password prompt dialog, you may try to take a look at the KB
link below.
Internet Explorer May Prompt You for a Password
http://support.microsoft.com/?id=258063

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #13

P: n/a
Thanks for your help Peter. I have given up and submitted on this one as it
seems easier to work around than to correct.
""Peter Huang"" <v-******@online.microsoft.com> wrote in message
news:ru**************@cpmsftngxa06.phx.gbl...
Hi,

As for the IE password prompt dialog, you may try to take a look at the KB
link below.
Internet Explorer May Prompt You for a Password
http://support.microsoft.com/?id=258063

Best regards,

Peter Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 20 '05 #14

P: n/a
Hi,

I am having the same problem. Have tried everything above, read all the docs etc and am making no progress. Is there a solution?

Thanks
Richard

---
Posted using Wimdows.net NntpNews Component -

Post Made from http://www.DotNetJunkies.com/newsgroups Our newsgroup engine supports Post Alerts, Ratings, and Searching.
Nov 21 '05 #15

This discussion thread is closed

Replies have been disabled for this discussion.