By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,771 Members | 1,709 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,771 IT Pros & Developers. It's quick & easy.

MsiLoadr.Bin 'Interface not registered'

P: n/a
Trying to Create a msi (Setup project) for a service and I received
the following Error:
D:\Projects\TestSetup.vdproj Could not find file 'D:\Program
Files\Microsoft Visual Studio
..NET\Common7\Tools\Deployment\.\MsiRedist\1033\Ms iLoadr.Bin'
'Interface not registered'

Searching through Google, did not immediately produce results. I
found a related error. There was a solution that worked for Me. Here
it is:

1. You need to reregister every OCX, Exe and DLL. Create a CMD file
with the following three lines:
for %%v in ( *.dll ) do regsvr32 /s %%v
for %%v in ( *.exe ) do regsvr32 /s %%v
for %%v in ( *.ocx ) do regsvr32 /s %%v

2. Then run it out of two directories.
WINNT\SYSTEM32
WINNT\SYSTEM32\WBEM

3. Open MSVS and rebuild. Mine worked, I hope your does too!
Special Thanks to those who found that this would fix the problem.
Regsvr32 produced 4 errors while running the .bat file in the system32
directory.

I started MSVS up and tried to build the msi and it worked.

I posted this because several answers suggest that you could only
reinstall the operating system and Visual Studio to fix this problem.
(My system was Windows 2000 pro) MSVS 7.1.3088 Framework 1.1.4322
Nov 20 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.