470,648 Members | 1,396 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,648 developers. It's quick & easy.

Problem with .Net Framework!

Hello
I am novice in VB.NET . I have developed a sample HelloWorld program and a setup application for it. VB.NET warned me that the client machine should install .NET Framework (DOTNETFX.EXE) in order to run the application. I tried it in my Windows ME and found a message "Setup cannot access Windows Installer components. Setup cannot continue." and it terminates. I can not run the setup application. I have found a log file in the Temp folder:

[12/06/03,23:20:19] Starting Install.exe
[12/06/03,23:20:19] Parsing switches from commandline: C:\WINDOWS\TEMP\IXP000.TMP\Install.exe
[12/06/03,23:20:19] SourceDir: C:\WINDOWS\TEMP\IXP000.TMP\
[12/06/03,23:20:19] Install started
[12/06/03,23:20:19] Checking system requirements
[12/06/03,23:20:19] OS: Win Millenium
[12/06/03,23:20:19] Ver: Second Edition
[12/06/03,23:20:19] SP:
[12/06/03,23:20:19] Checking Internet Explorer Version
[12/06/03,23:20:19] Looking for 5.0.2919.6307
[12/06/03,23:20:19] Found Internet Explorer Version: 5.50.4134.0100
[12/06/03,23:20:19] Internet Explorer Version is OK...
[12/06/03,23:20:19] System meets minimum requirements
[12/06/03,23:20:19] Checking Windows Installer version...
[12/06/03,23:20:19] Trying to load msi.dll
[12/06/03,23:20:19] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
[12/06/03,23:20:19] Cannot find Windows Installer.
[12/06/03,23:20:19] Finished Checking Windows Installer version.
[12/06/03,23:20:19] Preparing Dialog
[12/06/03,23:20:19] Message: Microsoft .NET Framework Setup needs to update the Microsoft Windows Installer components before Setup can continue. Proceed with installation?
[12/06/03,23:20:19] Installing Windows Installer
[12/06/03,23:20:19] Running InstMsi.exe /c:"msiinst /delayrebootq"
[12/06/03,23:20:24] Windows Installer Installation returned 0
[12/06/03,23:20:24]

[InstMsi.exe]

ReturnCode=0
[12/06/03,23:20:24] Searching for MSI: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
[12/06/03,23:20:24] Reading Properties from MSI database: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
[12/06/03,23:20:24] Reading URTVersion
[12/06/03,23:20:24] Trying to load msi.dll
[12/06/03,23:20:24] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
[12/06/03,23:20:24] Preparing Dialog
[12/06/03,23:20:24] Message: Setup cannot access Windows Installer components. Setup cannot continue.
[12/06/03,23:20:25] Install.exe returning 4099
[12/06/03,23:20:25]

[Install.exe]

ReturnCode=4099

Is this possible to run .NET applications on Windows 9x? Any help will be appreciated. Thank you!

Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.

Nov 20 '05 #1
6 1205
Isn't it that the receiving machine where you intend to install must have the right msi package installed?

If it is for Windows 95, 98 or ME http://www.microsoft.com/downloads/d...2-DE3BB768148F may be valuable.

Regards...
"Tanzim Saqib" <tz****@hotmail.com> wrote in message news:uf**************@TK2MSFTNGP12.phx.gbl...
Hello
I am novice in VB.NET . I have developed a sample HelloWorld program and a setup application for it. VB.NET warned me that the client machine should install .NET Framework (DOTNETFX.EXE) in order to run the application. I tried it in my Windows ME and found a message "Setup cannot access Windows Installer components. Setup cannot continue." and it terminates. I can not run the setup application. I have found a log file in the Temp folder:

[12/06/03,23:20:19] Starting Install.exe
[12/06/03,23:20:19] Parsing switches from commandline: C:\WINDOWS\TEMP\IXP000.TMP\Install.exe
[12/06/03,23:20:19] SourceDir: C:\WINDOWS\TEMP\IXP000.TMP\
[12/06/03,23:20:19] Install started
[12/06/03,23:20:19] Checking system requirements
[12/06/03,23:20:19] OS: Win Millenium
[12/06/03,23:20:19] Ver: Second Edition
[12/06/03,23:20:19] SP:
[12/06/03,23:20:19] Checking Internet Explorer Version
[12/06/03,23:20:19] Looking for 5.0.2919.6307
[12/06/03,23:20:19] Found Internet Explorer Version: 5.50.4134.0100
[12/06/03,23:20:19] Internet Explorer Version is OK...
[12/06/03,23:20:19] System meets minimum requirements
[12/06/03,23:20:19] Checking Windows Installer version...
[12/06/03,23:20:19] Trying to load msi.dll
[12/06/03,23:20:19] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
[12/06/03,23:20:19] Cannot find Windows Installer.
[12/06/03,23:20:19] Finished Checking Windows Installer version.
[12/06/03,23:20:19] Preparing Dialog
[12/06/03,23:20:19] Message: Microsoft .NET Framework Setup needs to update the Microsoft Windows Installer components before Setup can continue. Proceed with installation?
[12/06/03,23:20:19] Installing Windows Installer
[12/06/03,23:20:19] Running InstMsi.exe /c:"msiinst /delayrebootq"
[12/06/03,23:20:24] Windows Installer Installation returned 0
[12/06/03,23:20:24]

[InstMsi.exe]

ReturnCode=0
[12/06/03,23:20:24] Searching for MSI: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
[12/06/03,23:20:24] Reading Properties from MSI database: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
[12/06/03,23:20:24] Reading URTVersion
[12/06/03,23:20:24] Trying to load msi.dll
[12/06/03,23:20:24] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
[12/06/03,23:20:24] Preparing Dialog
[12/06/03,23:20:24] Message: Setup cannot access Windows Installer components. Setup cannot continue.
[12/06/03,23:20:25] Install.exe returning 4099
[12/06/03,23:20:25]

[Install.exe]

ReturnCode=4099

Is this possible to run .NET applications on Windows 9x? Any help will be appreciated. Thank you!

Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.


Nov 20 '05 #2
Thanks for replying. I am pretty sure that Windows Installer is installed. How can I know the version?

Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.

Nov 20 '05 #3
I've installed that file couple minutes ago and found the message "This service already exists."
Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.

Nov 20 '05 #4
And you found this on the machine you are trying to install the .msi? Perhaps you need to remove and re-install the latest version. Just a guess.
"Tanzim Saqib" <tz****@hotmail.com> wrote in message news:ec***************@TK2MSFTNGP11.phx.gbl...
I've installed that file couple minutes ago and found the message "This service already exists."
Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.


Nov 20 '05 #5
Yes, I am trying to install on my client machine which runs on Windows ME. How can I remove MSI?? Thanks again!
Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.

Nov 20 '05 #6
I never tried uninstalling it myself. So I am referring you to this link (Google is my friend.) in the hopes that it may help you. http://appdeploy.com/faq/windowsinstaller.shtml

"Tanzim Saqib" <tz****@hotmail.com> wrote in message news:%2****************@TK2MSFTNGP12.phx.gbl...
Yes, I am trying to install on my client machine which runs on Windows ME. How can I remove MSI?? Thanks again!
Tanzim Saqib

Problemsetter, ACM Valladolid Online Judge, Spain.
Website: http://tanzim.tk


This posting is provided "AS IS" with no warranties.


Nov 20 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

7 posts views Thread by Ankit Aneja | last post: by
5 posts views Thread by Dany C. | last post: by
1 post views Thread by aartinair | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.