By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,978 Members | 1,467 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,978 IT Pros & Developers. It's quick & easy.

Setup project problem

P: n/a
In my solution's Setup project, I'm adding a folder to the user's
Start Menu, and putting a couple of shortcuts in it. When I use
Add/Remove Programs to uninstall the application, the shortcuts are
deleted, but the folder stays there. Any thoughts on how I can cause
the folder to be deleted as well? Thanks.
Nov 20 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Tony I could not repro this, could you include some more information about this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************************@msnews.microsoft.com >
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|
Nov 20 '05 #2

P: n/a
Tony I could not repro this, could you include some more information about this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************************@msnews.microsoft.com >
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|
Nov 20 '05 #3

P: n/a
Hi Todd,

Some of us are wondering why just about every response from an MSFT account
includes the entire message header in the response. So far the only answer
to our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
Nobody else quotes all this stuff. It borders on incredible that every MSFT
posting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do it
consistently. Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@online.microsoft.com> wrote in message
news:JC**************@cpmsftngxa06.phx.gbl... Tony I could not repro this, could you include some more information about this issue? What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights. --------------------
--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************************@msnews.microsoft.com >
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|

Nov 20 '05 #4

P: n/a
It's the default from the tool we are using... that's all there is to it.

---
David Guyer - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------

Hi Todd,

Some of us are wondering why just about every response from an MSFT account
includes the entire message header in the response. So far the only answer
to our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
Nobody else quotes all this stuff. It borders on incredible that every

MSFTposting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do it
consistently. Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@online.microsoft.com> wrote in message
news:JC**************@cpmsftngxa06.phx.gbl...
Tony I could not repro this, could you include some more information
aboutthis issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no

rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************************@msnews.microsoft.com >
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|



Nov 20 '05 #5

P: n/a
Thanks David,

Since it is only the "default" it is possible to change the behavior right?
I'm not suggesting that you do (though it looks like you might have) but
doesn't it look like extraneous information? In that case it would seem
sensible if the MSFT-folk turned the feature off. If it helped anything I'd
suggest we all turn it on but (at least to me) it doesn't appear to make the
response any clearer.

Thanks for responding...
"David Guyer [MS]" <da****@online.microsoft.com> wrote in message
news:p8**************@cpmsftngxa07.phx.gbl...
It's the default from the tool we are using... that's all there is to it.

---
David Guyer - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights. --------------------

Hi Todd,

Some of us are wondering why just about every response from an MSFT accountincludes the entire message header in the response. So far the only answerto our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326 | X-Tomcat-NG: microsoft.public.dotnet.languages.vb


Nobody else quotes all this stuff. It borders on incredible that every

MSFT
posting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do itconsistently. Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@online.microsoft.com> wrote in message
news:JC**************@cpmsftngxa06.phx.gbl...
Tony I could not repro this, could you include some more information

about
this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no

rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************************@msnews.microsoft.com >
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: pcp243943pcs.howard01.md.comcast.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.vb:156326 | X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|


Nov 20 '05 #6

P: n/a
I'm on Windows XP with VS 2003, version 7.1.3088, and .Net Framework
version 1.1.4322. I didn't do anything to change the properties of
the folder I created in the IDE; it's not hidden or anything.

Thanks for your help.

--> From: td******@online.microsoft.com

Tony I could not repro this, could you include some more information
about this issue? What OS are you running on? What version of Visual
Studio? What are the properties of the folder that you created?
--> From: Tony Vitonis
In my solution's Setup project, I'm adding a folder to the user's
Start Menu, and putting a couple of shortcuts in it. When I use
Add/Remove Programs to uninstall the application, the shortcuts are
deleted, but the folder stays there. Any thoughts on how I can
cause the folder to be deleted as well? Thanks.

Nov 20 '05 #7

P: n/a
Tony, I still could not repro this on my machine but I found mention of a similiar problem occuring on Windows NT. There are ways to solve this, you can
create a script that deletes the folder and run it as a custom action on your uninstall step. This is by no means an ideal solution but it should work for you. If
this does not work for you please respond to this thread and we will figure out something that will.

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------

--------------------
| From: Tony Vitonis <no***@nowhere.com>
| Subject: RE: Setup project problem
|
| I'm on Windows XP with VS 2003, version 7.1.3088, and .Net Framework
| version 1.1.4322. I didn't do anything to change the properties of
| the folder I created in the IDE; it's not hidden or anything.
|
| Thanks for your help.
|
| --> From: td******@online.microsoft.com
| >
| > Tony I could not repro this, could you include some more information
| > about this issue? What OS are you running on? What version of Visual
| > Studio? What are the properties of the folder that you created?
| >
| --> From: Tony Vitonis
| >
| > In my solution's Setup project, I'm adding a folder to the user's
| > Start Menu, and putting a couple of shortcuts in it. When I use
| > Add/Remove Programs to uninstall the application, the shortcuts are
| > deleted, but the folder stays there. Any thoughts on how I can
| > cause the folder to be deleted as well? Thanks.
|

Nov 20 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.