By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,680 Members | 1,363 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,680 IT Pros & Developers. It's quick & easy.

Server Error in '/' Application.

P: n/a
I have no idea what this run-time error about. Any ideas? I already change
the web.config file for the attribute <customErrors mode="Off"/> but still
not work.
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Nov 20 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
* "Matthew Louden" <jr********@hotmail.com> scripsit:
I have no idea what this run-time error about. Any ideas? I already change
the web.config file for the attribute <customErrors mode="Off"/> but still
not work.


Please do not post ASP.NET questions which are not related to VB.NET to
this group...

--
Herfried K. Wagner
MVP VB Classic, VB.NET
<http://www.mvps.org/dotnet>
Nov 20 '05 #2

P: n/a
I usually get this error if I haven't set up the folder as a vroot in the
IIS Manager yet.
"Matthew Louden" <jr********@hotmail.com> wrote in message
news:us**************@TK2MSFTNGP10.phx.gbl...
I have no idea what this run-time error about. Any ideas? I already change
the web.config file for the attribute <customErrors mode="Off"/> but still not work.
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web>
</configuration>

Nov 20 '05 #3

P: n/a
Do you have your virtual directory set up correctly and mapped to the
correct dir in IIS?
Is your assembly in a bin folder in the application root? Have you built
your assembly? Is it referencing a start up page? Are your application pools
running? Is IIS running? Answering one of those questions will solve your
problem

"Matthew Louden" <jr********@hotmail.com> wrote in message
news:us**************@TK2MSFTNGP10.phx.gbl...
I have no idea what this run-time error about. Any ideas? I already change
the web.config file for the attribute <customErrors mode="Off"/> but still not work.
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web>
</configuration>

Nov 20 '05 #4

P: n/a
what do you mean set up the folder as a vroot in IIS manager? The folder was
created by IIS manager when I created a new web application in VS.NET.
And VS.NET will create a new user called ASPNET automatically.
Even I add permission to ASPNET for that application, still not working.

I don't know if the error is IIS permission problem, or SQL permission
problem?

"Joshua Flanagan" <jo**@msnews.com> wrote in message
news:#2**************@TK2MSFTNGP10.phx.gbl...
I usually get this error if I haven't set up the folder as a vroot in the
IIS Manager yet.
"Matthew Louden" <jr********@hotmail.com> wrote in message
news:us**************@TK2MSFTNGP10.phx.gbl...
I have no idea what this run-time error about. Any ideas? I already change the web.config file for the attribute <customErrors mode="Off"/> but

still
not work.
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors> tag within a

"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the

application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"

defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>




Nov 20 '05 #5

P: n/a
what do you mean set up the folder as a vroot in IIS manager? The folder was
created by IIS manager when I created a new web application in VS.NET.
And VS.NET will create a new user called ASPNET automatically.
Even I add permission to ASPNET for that application, still not working.

I don't know if the error is IIS permission problem, or SQL permission
problem?
"Joshua Flanagan" <jo**@msnews.com> wrote in message
news:#2**************@TK2MSFTNGP10.phx.gbl...
I usually get this error if I haven't set up the folder as a vroot in the
IIS Manager yet.
"Matthew Louden" <jr********@hotmail.com> wrote in message
news:us**************@TK2MSFTNGP10.phx.gbl...
I have no idea what this run-time error about. Any ideas? I already change the web.config file for the attribute <customErrors mode="Off"/> but

still
not work.
Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors> tag within a

"web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the

application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"

defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


Nov 20 '05 #6

P: n/a
> I have no idea what this run-time error about.

There was a thread on this a day or two ago, but I don't remember the
solution.

(i) Is the problem on your development or live hosting platform?

(ii) If the latter, are you sure you uploaded the dll containing all the
compiled code-behind code (a basic question I know, but sometimes worth
checking)

HTH

Lauchlan M
Nov 20 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.