By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,579 Members | 1,670 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,579 IT Pros & Developers. It's quick & easy.

problem with MDI form

P: n/a
In my Form I've a combobox populated by a dataset, in the form load I set
the selectedvalue property of the combobox to -1 in order to start with no
value in the combobox, it works ok

But when I've set the MDIParent property of the form to a parent form, the
combobox is populated by the first row, and the function
"SelectedIndexChanged" is invoked.

I don't understand how the MDIParent property can change the behaviour of
the combobox...

Does anyone have the same problem, or any idea please.

Thanks



Nov 20 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a


Touf--

I am just guessing but I suspect that the child form bubbles events back up
to the parent.

HTH.

--Mark
"touf" <to******@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
In my Form I've a combobox populated by a dataset, in the form load I set
the selectedvalue property of the combobox to -1 in order to start with no
value in the combobox, it works ok

But when I've set the MDIParent property of the form to a parent form, the
combobox is populated by the first row, and the function
"SelectedIndexChanged" is invoked.

I don't understand how the MDIParent property can change the behaviour of
the combobox...

Does anyone have the same problem, or any idea please.

Thanks


Nov 20 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.