By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,578 Members | 1,617 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,578 IT Pros & Developers. It's quick & easy.

Backward Compatibility

P: n/a
Hi all,

I have an application created using a .Net Framework 1.1,
is it possible to run the same on Framework 1.0. if
yes ... then any extran thing (Coding ) to be
done ... ???? Pls help....

Thanx,
Justine
Nov 20 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Justine wrote:
Hi all,

I have an application created using a .Net Framework 1.1,
is it possible to run the same on Framework 1.0. if
yes ... then any extran thing (Coding ) to be
done ... ???? Pls help....

Thanx,
Justine


Justine,

That depends :) If you made use of classes or members of classes that were
added in 1.1 - then no, they won't work on framework 1.0. Also, you might
want to check out the breaking change list here:

http://www.gotdotnet.com/team/change...1\default.aspx

Now, assuming that you aren't affected by any of these items - then yes,
your code will run. In fact, I have a windows service that was written in
1.1 and running on the 1.0 framework right now :) If you look at the
solution settings, I believe you will see an option in VS.NET 2003 that
lets you specify the framework target. This doesn't change the compiler,
it simply generates and app.config file that specifies the framework
versions that the program can run on...

Tom Shelton

PS: I would be more specific, but I'm sitting on my Linux box right now -
so I don't have access to my VS.NET to give you specific instructions...
I'm sure someone else will jump in and give you the actual details.
Nov 20 '05 #2

P: n/a
Thanx a lot Tom....
-----Original Message-----
Justine wrote:
Hi all,

I have an application created using a .Net Framework 1.1, is it possible to run the same on Framework 1.0. if
yes ... then any extran thing (Coding ) to be
done ... ???? Pls help....

Thanx,
Justine
Justine,

That depends :) If you made use of classes or members of

classes that wereadded in 1.1 - then no, they won't work on framework 1.0. Also, you mightwant to check out the breaking change list here:

http://www.gotdotnet.com/team/change...rwards1.0to1.1 \default.aspx
Now, assuming that you aren't affected by any of these items - then yes,your code will run. In fact, I have a windows service that was written in1.1 and running on the 1.0 framework right now :) If you look at thesolution settings, I believe you will see an option in VS.NET 2003 thatlets you specify the framework target. This doesn't change the compiler,it simply generates and app.config file that specifies the frameworkversions that the program can run on...

Tom Shelton

PS: I would be more specific, but I'm sitting on my Linux box right now -so I don't have access to my VS.NET to give you specific instructions...I'm sure someone else will jump in and give you the actual details..

Nov 20 '05 #3

P: n/a
Hello,

"Justine" <am***********@hotmail.com> schrieb:
I have an application created using a .Net Framework 1.1,
is it possible to run the same on Framework 1.0. if
yes ... then any extran thing (Coding ) to be
done ... ???? Pls help....


Version comparison
http://msdn.microsoft.com/netframewo...ioncomparison/

General changes
http://www.gotdotnet.com/team/changeinfo/

API changes
http://www.gotdotnet.com/team/upgrade/apiChanges.aspx

Related Topics

"Side-by-Side Execution"
http://msdn.microsoft.com/library/en...dexsidenet.asp

--
Herfried K. Wagner
MVP VB Classic, VB.NET
http://www.mvps.org/dotnet
Nov 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.