473,856 Members | 1,662 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

[HELP] File or assembly name XXX , or one of its dependencies, was not found

Hi,

i have some problem to run my dll's (assemblies) on the production server.

I have 3 dll's which use each other.

Every thing is ok on my local machine where i developed them

but when i upload them to the server and after signing them in to the GAC
i m getting some errors.

from some reason the assembly looking for old version which is not exist
in the server .

File or assembly name XXX , or one of its dependencies, was not found.
Description: An unhandled exception occurred during the execution of the
current web request.
Please review the stack trace for more information
about the error and where it originated in the code.

Exception Details: System.IO.FileN otFoundExceptio n: File or assembly name
XXX, or one of its dependencies, was not found.
Assembly Load Trace: The following information can be helpful to determine
why the assembly 'XXX' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = XXX, Version=1.0.1.1 , Culture=neutral ,
PublicKeyToken= aaabbbccc
(Fully-specified)
===

My aspx file contain the following code :

<%@ Import Namespace="XXX" %>
<%@ Assembly Name="XXX, Version=1.0.0.0 , Culture=Neutral ,
PublicKeyToken= aaabbbccc, Custom=null" %>

And i have this redirect in the machine.config :
<runtime>

<assemblyBindin g xmlns="urn:sche ms-microsoft-com:asm.v1">

<dependentAssem bly>

<assemblyIdenti ty name="XXX" publicKeyToken= "aaabbbccc"
culture="Neutra l" />

<bindingRedirec t oldVersion="1.0 .0.0" newVersion="1.0 .1.2"/>

</dependentAssemb ly>

</assemblyBinding >

</runtime>

Please notice that my current version is 1.0.1.2 and the he looking for
old version 1.0.1.1

any idea ?

how can i prevent this dependency ?

please help,

10x
--
Best Regards ,

Tiraman :-)
Nov 20 '05 #1
4 1625
Try taking out the references 'on the server', and putting them back and
then rebuild

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:%2******** **********@TK2M SFTNGP10.phx.gb l...
Hi,

i have some problem to run my dll's (assemblies) on the production server.
I have 3 dll's which use each other.

Every thing is ok on my local machine where i developed them

but when i upload them to the server and after signing them in to the GAC i m getting some errors.

from some reason the assembly looking for old version which is not exist
in the server .

File or assembly name XXX , or one of its dependencies, was not found.
Description: An unhandled exception occurred during the execution of the
current web request.
Please review the stack trace for more information
about the error and where it originated in the code.

Exception Details: System.IO.FileN otFoundExceptio n: File or assembly name XXX, or one of its dependencies, was not found.
Assembly Load Trace: The following information can be helpful to determine why the assembly 'XXX' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = XXX, Version=1.0.1.1 , Culture=neutral ,
PublicKeyToken= aaabbbccc
(Fully-specified)
===

My aspx file contain the following code :

<%@ Import Namespace="XXX" %>
<%@ Assembly Name="XXX, Version=1.0.0.0 , Culture=Neutral ,
PublicKeyToken= aaabbbccc, Custom=null" %>

And i have this redirect in the machine.config :
<runtime>

<assemblyBindin g xmlns="urn:sche ms-microsoft-com:asm.v1">

<dependentAssem bly>

<assemblyIdenti ty name="XXX" publicKeyToken= "aaabbbccc"
culture="Neutra l" />

<bindingRedirec t oldVersion="1.0 .0.0" newVersion="1.0 .1.2"/>
</dependentAssemb ly>

</assemblyBinding >

</runtime>

Please notice that my current version is 1.0.1.2 and the he looking for
old version 1.0.1.1

any idea ?

how can i prevent this dependency ?

please help,

10x
--
Best Regards ,

Tiraman :-)

Nov 20 '05 #2
what do you mean by taking out the references on the server ?
"One Handed Man ( OHM - Terry Burns )" <news.microsoft .com> wrote in message
news:e3******** *****@TK2MSFTNG P11.phx.gbl...
Try taking out the references 'on the server', and putting them back and
then rebuild

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:%2******** **********@TK2M SFTNGP10.phx.gb l...
Hi,

i have some problem to run my dll's (assemblies) on the production

server.

I have 3 dll's which use each other.

Every thing is ok on my local machine where i developed them

but when i upload them to the server and after signing them in to the

GAC
i m getting some errors.

from some reason the assembly looking for old version which is not exist in the server .

File or assembly name XXX , or one of its dependencies, was not found.
Description: An unhandled exception occurred during the execution of the current web request.
Please review the stack trace for more information
about the error and where it originated in the code.

Exception Details: System.IO.FileN otFoundExceptio n: File or assembly

name
XXX, or one of its dependencies, was not found.
Assembly Load Trace: The following information can be helpful to

determine
why the assembly 'XXX' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = XXX, Version=1.0.1.1 , Culture=neutral ,
PublicKeyToken= aaabbbccc
(Fully-specified)
===

My aspx file contain the following code :

<%@ Import Namespace="XXX" %>
<%@ Assembly Name="XXX, Version=1.0.0.0 , Culture=Neutral ,
PublicKeyToken= aaabbbccc, Custom=null" %>

And i have this redirect in the machine.config :
<runtime>

<assemblyBindin g xmlns="urn:sche ms-microsoft-com:asm.v1">

<dependentAssem bly>

<assemblyIdenti ty name="XXX" publicKeyToken= "aaabbbccc"
culture="Neutra l" />

<bindingRedirec t oldVersion="1.0 .0.0"

newVersion="1.0 .1.2"/>

</dependentAssemb ly>

</assemblyBinding >

</runtime>

Please notice that my current version is 1.0.1.2 and the he looking for old version 1.0.1.1

any idea ?

how can i prevent this dependency ?

please help,

10x
--
Best Regards ,

Tiraman :-)


Nov 20 '05 #3
Your project has references to the various DLL's these may be broken if you
simply copied this to the server. They may need correcting

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:ug******** ******@TK2MSFTN GP11.phx.gbl...
what do you mean by taking out the references on the server ?
"One Handed Man ( OHM - Terry Burns )" <news.microsoft .com> wrote in message news:e3******** *****@TK2MSFTNG P11.phx.gbl...
Try taking out the references 'on the server', and putting them back and
then rebuild

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:%2******** **********@TK2M SFTNGP10.phx.gb l...
Hi,

i have some problem to run my dll's (assemblies) on the production

server.

I have 3 dll's which use each other.

Every thing is ok on my local machine where i developed them

but when i upload them to the server and after signing them in to the
GAC
i m getting some errors.

from some reason the assembly looking for old version which is not exist in the server .

File or assembly name XXX , or one of its dependencies, was not
found. Description: An unhandled exception occurred during the execution of

the current web request.
Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileN otFoundExceptio n: File or assembly

name
XXX, or one of its dependencies, was not found.
Assembly Load Trace: The following information can be helpful to

determine
why the assembly 'XXX' could not be loaded.

=== Pre-bind state information ===
LOG: DisplayName = XXX, Version=1.0.1.1 , Culture=neutral ,
PublicKeyToken= aaabbbccc
(Fully-specified)
===

My aspx file contain the following code :

<%@ Import Namespace="XXX" %>
<%@ Assembly Name="XXX, Version=1.0.0.0 , Culture=Neutral ,
PublicKeyToken= aaabbbccc, Custom=null" %>

And i have this redirect in the machine.config :
<runtime>

<assemblyBindin g xmlns="urn:sche ms-microsoft-com:asm.v1">

<dependentAssem bly>

<assemblyIdenti ty name="XXX" publicKeyToken= "aaabbbccc" culture="Neutra l" />

<bindingRedirec t oldVersion="1.0 .0.0"

newVersion="1.0 .1.2"/>

</dependentAssemb ly>

</assemblyBinding >

</runtime>

Please notice that my current version is 1.0.1.2 and the he looking for old version 1.0.1.1

any idea ?

how can i prevent this dependency ?

please help,

10x
--
Best Regards ,

Tiraman :-)



Nov 20 '05 #4
Thanks,
i will check this.
bye

"One Handed Man ( OHM - Terry Burns )" <news.microsoft .com> wrote in message
news:uy******** ******@tk2msftn gp13.phx.gbl...
Your project has references to the various DLL's these may be broken if you simply copied this to the server. They may need correcting

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:ug******** ******@TK2MSFTN GP11.phx.gbl...
what do you mean by taking out the references on the server ?
"One Handed Man ( OHM - Terry Burns )" <news.microsoft .com> wrote in

message
news:e3******** *****@TK2MSFTNG P11.phx.gbl...
Try taking out the references 'on the server', and putting them back and then rebuild

--

OHM ( Terry Burns )
. . . One-Handed-Man . . .

Time flies when you don't know what you're doing

"Tiraman" <ti*****@netvis ion.net.il> wrote in message
news:%2******** **********@TK2M SFTNGP10.phx.gb l...
> Hi,
>
> i have some problem to run my dll's (assemblies) on the production
server.
>
> I have 3 dll's which use each other.
>
> Every thing is ok on my local machine where i developed them
>
> but when i upload them to the server and after signing them in to the GAC
> i m getting some errors.
>
> from some reason the assembly looking for old version which is not

exist
> in the server .
>
> File or assembly name XXX , or one of its dependencies, was not found. > Description: An unhandled exception occurred during the execution of
the
> current web request.
> Please review the stack trace for more information > about the error and where it originated in the code.
>
> Exception Details: System.IO.FileN otFoundExceptio n: File or
assembly name
> XXX, or one of its dependencies, was not found.
> Assembly Load Trace: The following information can be helpful to
determine
> why the assembly 'XXX' could not be loaded.
>
> === Pre-bind state information ===
> LOG: DisplayName = XXX, Version=1.0.1.1 , Culture=neutral ,
> PublicKeyToken= aaabbbccc
> (Fully-specified)
> ===
>
>
>
> My aspx file contain the following code :
>
> <%@ Import Namespace="XXX" %>
> <%@ Assembly Name="XXX, Version=1.0.0.0 , Culture=Neutral ,
> PublicKeyToken= aaabbbccc, Custom=null" %>
>
> And i have this redirect in the machine.config :
>
>
> <runtime>
>
> <assemblyBindin g xmlns="urn:sche ms-microsoft-com:asm.v1">
>
> <dependentAssem bly>
>
> <assemblyIdenti ty name="XXX" publicKeyToken= "aaabbbccc" > culture="Neutra l" />
>
> <bindingRedirec t oldVersion="1.0 .0.0"
newVersion="1.0 .1.2"/>
>
> </dependentAssemb ly>
>
> </assemblyBinding >
>
> </runtime>
>
> Please notice that my current version is 1.0.1.2 and the he

looking for
> old version 1.0.1.1
>
> any idea ?
>
> how can i prevent this dependency ?
>
> please help,
>
> 10x
>
>
> --
> Best Regards ,
>
> Tiraman :-)
>
>



Nov 20 '05 #5

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
8782
by: stephan | last post by:
I know that this has been beaten to death but I can't seem to resolve my issues (I have 2 of them). I have created a class that exposes a public method which returns a datatable as a datasource for a Crystal Report. The method has a single argument which represents a parameter required by the Stored Procedure. When I generate the report in Crystal and run it using the class I built, it works fine. I've tried it with parameters and...
0
1950
by: karunakar | last post by:
Hi All I am not able to read the class name I want read the particular class name string path = System.Configuration.ConfigurationSettings.AppSettings; string className = path + ".User"; return (SCS.SR.IDAL.IUser) Assembly.Load(path).CreateInstance(className); ( This line iam getting Error)
3
1572
by: TM | last post by:
Asp.Net Experts, I am build a sample .Net in Asp.Net (c#) using VS.net 2003 with .NFW 1.1. 1. At first, it compiles successfully with "release" version. I ran it and it works fine. 2. Then I resize one of the textBox on the web form, then recompiled and I got this error: *********************************************************************
2
2322
by: aallee83 | last post by:
i'm new in asp.net after develop my solution i copied it on the server where I want it to run but something cares... WHAT?!?! thank you in advance File or assembly name System, or one of its dependencies, was not found. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
0
2002
by: Martinh | last post by:
Hi After invoking RetrieveData in a WebService I recieve the following response in a new window... I am running Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573 on IIS6 on Server 2003 Enterprise. Does anybody has a working solution for me? Martin
1
1273
by: news | last post by:
Hi, I have just deployed my private assembly in the bin directory of my ISP and I am getting the following error. I am pretty sure it is able to find my assemblyPLEASE tell me how can I find which dependencies are not being found( is there a way to trace the dependencies which are not found). I Just have ftp access to my isp server. Thanks you in advance, Peace,
1
5063
by: Olav Tollefsen | last post by:
I get the included error message when trying to run my ASP.NET application under Windows Server 2003 (with all updates installed). How can I troubleshoot this? Olav File or assembly name System.Xml, or one of its dependencies, was not found. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information
2
1768
by: Andrew Jocelyn | last post by:
Hi I get this error when I change something in the web.config file. When I build the VS projects and load the first web page the application runs fine. If I then make a save the web.config file I then get this error when I refresh the browser. I have to restart IIS to fix the problem. I've included the error info but it all looks very cryptic to me. How do I find out what's really happening and how to fix it? Thanks
3
4419
by: Richard Lewis Haggard | last post by:
We are having a lot of trouble with problems relating to failures relating to 'The located assembly's manifest definition with name 'xxx' does not match the assembly reference" but none of us here really understand how this could be an issue. The assemblies that the system is complaining about are ones that we build here and we're not changing version numbers on anything. The errors come and go with no apparent rhyme or reason. We do not...
0
9758
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
11049
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
10772
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10378
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9527
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
7086
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5754
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
2
4169
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
3195
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.