473,854 Members | 1,508 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Setup project problem

In my solution's Setup project, I'm adding a folder to the user's
Start Menu, and putting a couple of shortcuts in it. When I use
Add/Remove Programs to uninstall the application, the shortcuts are
deleted, but the folder stays there. Any thoughts on how I can cause
the folder to be deleted as well? Thanks.
Nov 20 '05 #1
7 1526
Tony I could not repro this, could you include some more information about this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************ ************@ms news.microsoft. com>
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|
Nov 20 '05 #2
Tony I could not repro this, could you include some more information about this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************ ************@ms news.microsoft. com>
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|
Nov 20 '05 #3
Hi Todd,

Some of us are wondering why just about every response from an MSFT account
includes the entire message header in the response. So far the only answer
to our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
Nobody else quotes all this stuff. It borders on incredible that every MSFT
posting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do it
consistently. Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@onlin e.microsoft.com > wrote in message
news:JC******** ******@cpmsftng xa06.phx.gbl... Tony I could not repro this, could you include some more information about this issue? What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights. --------------------
--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************ ************@ms news.microsoft. com>
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|

Nov 20 '05 #4
It's the default from the tool we are using... that's all there is to it.

---
David Guyer - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------

Hi Todd,

Some of us are wondering why just about every response from an MSFT account
includes the entire message header in the response. So far the only answer
to our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
Nobody else quotes all this stuff. It borders on incredible that every

MSFTposting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do it
consistently . Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@onlin e.microsoft.com > wrote in message
news:JC******* *******@cpmsftn gxa06.phx.gbl.. .
Tony I could not repro this, could you include some more information
aboutthis issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no

rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************ ************@ms news.microsoft. com>
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326
| X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|



Nov 20 '05 #5
Thanks David,

Since it is only the "default" it is possible to change the behavior right?
I'm not suggesting that you do (though it looks like you might have) but
doesn't it look like extraneous information? In that case it would seem
sensible if the MSFT-folk turned the feature off. If it helped anything I'd
suggest we all turn it on but (at least to me) it doesn't appear to make the
response any clearer.

Thanks for responding...
"David Guyer [MS]" <da****@online. microsoft.com> wrote in message
news:p8******** ******@cpmsftng xa07.phx.gbl...
It's the default from the tool we are using... that's all there is to it.

---
David Guyer - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights. --------------------

Hi Todd,

Some of us are wondering why just about every response from an MSFT accountincludes the entire message header in the response. So far the only answerto our query has been one that misinterpreted it to mean "quoting the
message contents" which is of course "common." What is atypical is
repeating the entire message "header" as in your response. See the
difference between my response to you, other people's responses to each
other and the MSFT responses?

See this?
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326 | X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb


Nobody else quotes all this stuff. It borders on incredible that every

MSFT
posting includes it. Is something in your newsreader setup wrong? Or
perhaps we need to modify ours in order to likewise echo all this.

It is so curious because only MSFT personnel are doing this and they do itconsistently . Any ideas, first what causes it and second how to stop it?
The quality of a response can be adversely affected by a dozen extraneous
lines of unrelated "stuff" don't you agree?

Tom

"Todd Derksen [MSFT]" <td******@onlin e.microsoft.com > wrote in message
news:JC******* *******@cpmsftn gxa06.phx.gbl.. .
Tony I could not repro this, could you include some more information

about
this issue?
What OS are you running on?
What version of Visual Studio?
What are the properties of the folder that you created?

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no

rights.
--------------------
--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: Setup project problem
| Date: Wed, 12 Nov 2003 20:13:48 -0500
| Message-ID: <MP************ ************@ms news.microsoft. com>
| Organization: The Vitonis Family
| MIME-Version: 1.0
| Content-Type: text/plain; charset="iso-8859-15"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: MicroPlanet Gravity v2.60
| Newsgroups: microsoft.publi c.dotnet.langua ges.vb
| NNTP-Posting-Host: pcp243943pcs.ho ward01.md.comca st.net 68.55.85.183
| Lines: 1
| Path: cpmsftngxa06.ph x.gbl!TK2MSFTNG P08.phx.gbl!TK2 MSFTNGP11.phx.g bl
| Xref: cpmsftngxa06.ph x.gbl microsoft.publi c.dotnet.langua ges.vb:156326 | X-Tomcat-NG: microsoft.publi c.dotnet.langua ges.vb
|
| In my solution's Setup project, I'm adding a folder to the user's
| Start Menu, and putting a couple of shortcuts in it. When I use
| Add/Remove Programs to uninstall the application, the shortcuts are
| deleted, but the folder stays there. Any thoughts on how I can cause
| the folder to be deleted as well? Thanks.
|


Nov 20 '05 #6
I'm on Windows XP with VS 2003, version 7.1.3088, and .Net Framework
version 1.1.4322. I didn't do anything to change the properties of
the folder I created in the IDE; it's not hidden or anything.

Thanks for your help.

--> From: td******@online .microsoft.com

Tony I could not repro this, could you include some more information
about this issue? What OS are you running on? What version of Visual
Studio? What are the properties of the folder that you created?
--> From: Tony Vitonis
In my solution's Setup project, I'm adding a folder to the user's
Start Menu, and putting a couple of shortcuts in it. When I use
Add/Remove Programs to uninstall the application, the shortcuts are
deleted, but the folder stays there. Any thoughts on how I can
cause the folder to be deleted as well? Thanks.

Nov 20 '05 #7
Tony, I still could not repro this on my machine but I found mention of a similiar problem occuring on Windows NT. There are ways to solve this, you can
create a script that deletes the folder and run it as a custom action on your uninstall step. This is by no means an ideal solution but it should work for you. If
this does not work for you please respond to this thread and we will figure out something that will.

------
Todd Derksen - VBQA Deployment Testing
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------

--------------------
| From: Tony Vitonis <no***@nowhere. com>
| Subject: RE: Setup project problem
|
| I'm on Windows XP with VS 2003, version 7.1.3088, and .Net Framework
| version 1.1.4322. I didn't do anything to change the properties of
| the folder I created in the IDE; it's not hidden or anything.
|
| Thanks for your help.
|
| --> From: td******@online .microsoft.com
| >
| > Tony I could not repro this, could you include some more information
| > about this issue? What OS are you running on? What version of Visual
| > Studio? What are the properties of the folder that you created?
| >
| --> From: Tony Vitonis
| >
| > In my solution's Setup project, I'm adding a folder to the user's
| > Start Menu, and putting a couple of shortcuts in it. When I use
| > Add/Remove Programs to uninstall the application, the shortcuts are
| > deleted, but the folder stays there. Any thoughts on how I can
| > cause the folder to be deleted as well? Thanks.
|

Nov 20 '05 #8

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

4
5312
by: pbj | last post by:
my application was created in vb.net, vs 2003. the setup project was also created in vs 2003. one of my application reviewers reported this: The .Net link that is included in the setup is not the correct link, it's outdated. The link should be changed from this http://msdn.microsoft.com/library/default.asp?url=/downloads/list/netdevframework.asp to the new link, which is this:...
0
1301
by: joe.bockskopf | last post by:
I am trying to add a setup project to an existing solution using VS.NET 2003. No matter what I do, VS.NET crashes while creating the project. I right click on the solution, select Add... New Project..., then select Web Setup Project. After a couple seconds I get the message : "Microsoft Development Environment has encountered a problem and needs to close. We are sorry for the inconvenience." I have also tried creating a regular...
1
1028
by: santhosh_176 | last post by:
:I Created a Pocket PC application for iPAQ 5450. Every thing went fine even installer creation. I could run the setup and install it into the actual device and worked fine. The application enables syncronization with remote database using merge replication. I found contradictory results while installing the application. I will mention here all the steps that I done while creating and installing setups. Result: Case 1: worked fine. ...
4
2478
by: Nick | last post by:
Hi, I have a windows application, wherein the solution consists of 5 projects. When I try to create a setup and deployment project for this solution, I'm somehow unable to add anything in project output group. I tried creating with a setup wizard, but it just doesn't give me an option to add projects, although I was able to add files into the setup. Moreover, creating a normal setup project also did not help. I tried to add a new...
0
1947
by: Adam Clauss | last post by:
I have a C++ COM Addin I wrote for Outlook (2002) using VS.Net 2002. Having completed it, I am now looking to create a setup project and install it on another machine. I created a setup project and added it to my solution (selecting the "Primary Output" as the files to include from my project). However, when I attempt to build the setup project (assuming a clean output directory), I get "Unrecoverable build error" - and NO other...
3
3706
by: Richard L Rosenheim | last post by:
I have an application that works, which is written in VB using Visual Studio 2003. Now, I'm trying to create a setup application for it. As the application uses Crystal Reports, I followed the instructions provided by Microsoft in http://msdn.microsoft.com/library/default.asp?url=/library/en-us/crystalmn/h tml/crtskdeployingwindowsapplications.asp When I attempt to build the setup application, I'm getting the following error in the...
4
2317
by: Howard Kaikow | last post by:
When I build a setup project, the dependency in the setup project is tied to the version in which it was built. Is there a way to build a setup project that can be used in both versions of the Framework? There is provision to build the app's .exe so that the .exe can be used in either version of the framework, is there not a way to do this for the setup project? I looked at the options, did not find any. Did I miss something? --
1
3605
by: rohan_from_mars | last post by:
I have a windows service and am also using Enterprise Library June 2005 version. Now i have created Setup and Deployment Project which installs the service. but how do i add EL dlls- Common.dll, Logging.dll, Configuration.dll, Data.dll into setup project so that it is also installed automatically. It should perform what the 'Install Services.bat ' performs. I have created ProjectInstaller.cs file also
0
1649
by: Nopik | last post by:
Hello. I have some problem with RemovePreviousVersions setting in my application.. I was searching the net for long time, I found a number of tips, but none of them is working. Here is what I do: 1) There is some application project, lets refer to it as Project1 2) I add setup project, and set it to include primary output of Project1 3) In setup project I ensure following:
1
4458
by: =?Utf-8?B?S2VpdGggRHVQb250?= | last post by:
I have created a setup project for a forms application that I will be deploying in the near future. I have added the primary output to the setup project and all dependencies have been correctly identified and included in the setup. Initial deployment on a workstation works fine all files being deployed to the correct location (C:\Program Files\Company Name\Application Name\). The problem I am seeing occurs when I attempt to deploy an...
0
9751
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10682
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
10758
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10371
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
7915
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
7082
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5743
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
2
4159
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
3187
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.