By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,417 Members | 1,825 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,417 IT Pros & Developers. It's quick & easy.

problem on NoMachine NX Client. (displays connection error when logging in)

P: 9
I'm using a NoMachine - NX Client for Windows and when I log in,
I get a "connection error" ( thats what exactly is displayed)
Here are the details of the error.

NX> 203 NXSSH running with pid: 756
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 202.92.128.92 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-50 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: eee11_200921061
NX> 102 Password:
NX> 103 Welcome to: opensuse user: eee11_200921061
NX> 105 listsession --user="eee11_200921061" --status="suspended,running" --geometry="1280x800x32+render" --type="unix-gnome"
NX> 127 Sessions list of user 'eee11_200921061' for reconnect:

Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: ok for user: eee11_200921061
NX> 105 startsession --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --media="0" --session="karensiruma" --type="unix-gnome" --geometry="1274x738" --kbtype="pc102/en_US" --screeninfo="1274x738x32+render"

NX> 1000 NXNODE - Version 1.5.0-50 OS (GPL)
NX> 700 Session id: opensuse-1000-CEAF403AB601087E8A021088CBC92767
NX> 705 Session display: 1000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: a436c034e6abe2157da39d7d65e9c23e
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: a436c034e6abe2157da39d7d65e9c23e
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1.
NX> 1006 Session status: closed
/usr/bin/nxserver: line 1081: 11435 Terminated sleep $AGENT_STARTUP_TIMEOUT
Can't open /var/lib/nxserver/db/running/sessionId{CEAF403AB601087E8A021088CBC92767}: No such file or directory.
NX> 1001 Bye.
NX> 280 Exiting on signal: 15

Any suggestions on how to make this work?
Thanks a lot in advance.
Jan 1 '10 #1
Share this Question
Share on Google+
2 Replies


ashitpro
Expert 100+
P: 542
http://www.google.co.in/search?q=Can...ient=firefox-a

See if this could be helpful..
Jan 6 '10 #2

P: 1
So I was having the same error output. And I stumbled upon this. I was not able to get NX to successfully work and the details that it output were very similar to yours. I was trying to login with the account I had created for myself on my BackTrack 5 R3 VM and was struggling. I noticed my credentials were passing through fine and logging in and then it was hanging. I on a whim tried logging in through XM with root credentials and it magically worked. I have picture now and it works just fine. I read a lot of forums and articles and none of them told me to log in as root. But I did and its the only thing that worked for me.
Oct 25 '12 #3

Post your reply

Sign in to post your reply or Sign up for a free account.