By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,332 Members | 1,103 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,332 IT Pros & Developers. It's quick & easy.

Kernel errors when installing ndiswrapper

epots9
Expert 100+
P: 1,351
I'm trying to install ndiswrapper so i can get my wireless card working in my fedora environment.

I move to the ndiswrapper directory that i created (using terminal with admin rights) and i run make uninstall...which seems to be working fine but when i run make i get the following error:

Expand|Select|Wrap|Line Numbers
  1. make -C driver
  2. make[1]: Entering directory `/home/<user>/Desktop/ndiswrapper-1.53/Driver`
  3. makefile:23: *** Kernel tree not found - please set KBUILD to fonfigure kernel.
  4.    Stop.
  5. make[1]: Leaving directory `/home/<user>/Desktop/ndiswrapper-1.53/Driver`
  6. make: *** [all] Error 2
  7.  
I'm using Fedora 9 and ndiswrapper 1.53.

Any thoughts or ideas on what i can do to get it working?

Thanks in advance.
Jun 3 '08 #1
Share this Question
Share on Google+
4 Replies

micmast
100+
P: 144
make sure you have all the dependencies including the kernel source and header files. Most likely this would have caused this error. You might also wanna check that your environment is correctly set
Jun 4 '08 #2

epots9
Expert 100+
P: 1,351
alright after alot of reading/searching and work i reinstalled fedora got all the updates, download the kernel header and source.

blacklisted b43 and ssb
add the line modprobe ndiswrapper to the rc.local file

and everything seems to working!! :D

but one thing i have noticed is if the router is not broadcasting the SSID it will not auto connect...is there any way to fix this?

i broadcasted the ssid so i could make the first connection (profile has been saved) but unlike windows if the ssid isn't always broadcasted it won't connect...any way to fix this like adding more options to the connection profile?
Jun 4 '08 #3

micmast
100+
P: 144
hmm I never had the problem before... can you see the SSID when you type:
> iwlist scanning


that should display all the SSIDS it can find to connect to.
Jun 5 '08 #4

P: 1
Hello there....
I'm anticipating the same problems... i'm a newbie to Fedora
Would you be very kind to help me with the set-up you went through in order to get your USB stick to work.
Thank you
Don
May 2 '09 #5

Post your reply

Sign in to post your reply or Sign up for a free account.