By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,247 Members | 1,223 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,247 IT Pros & Developers. It's quick & easy.

log4cpp make error extra ';' in Manipulator.hh

Colloid Snake
P: 144

I was attempting to configure log4cpp to monitor some logs on my *nix box, and when I run 'make' I get this error message:

Expand|Select|Wrap|Line Numbers
  1. [user@sandbox]# make
  2. [... lots of output snipped ...]
  3. g++ -DHAVE_CONFIG_H -I. -I. -I../include -I../include -g -02 -Wall -Wno-unused -pedantic -MT FileAppender.lo -MD -MP -MF .deps/FileAppender.Tpo -c FileAppender.cpp -fPIC -DPIC -o .libs/FileAppender.o
  4. ../include/log4cpp/Manipulator.hh:29: error: extra ';'
  5. make[1]: *** [FileAppender.lo] Error 1
  6. make[1]: Leaving directory `/home/user/unzip/log4cpp-0.3.5rc3/src'
  7. make: *** [all-recursive] Errro1
  8. [user@sandbox]#
I tried playing around with the Manipulator.hh file (removing/moving/adding ';'s) to no avail, and am now stuck. Any help is appreciated!

Extra info, if necessary:

gcc version 4.1.0 20060304 (Red Hat 4.1.0-3)

Dec 1 '06 #1
Share this Question
Share on Google+
2 Replies

P: 1
I am having the same trouble attempting to compile on rhel4. Has anyone encountered this and fixed it?

Mar 5 '07 #2

P: 1
I removed the extra semicolon (;) after the end of namespace bracket and before the #endif in include/log4cpp/Manipulator.hh

It then compiled.

Jul 17 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.