By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,695 Members | 1,597 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,695 IT Pros & Developers. It's quick & easy.

Report Builder 2.0 - First row only

P: 6
I am trying to create a data extract report in report builder 2.0 in sql 2008. I developed the report on my server in report builder 3.0 (2008R@) and it ran fine. I duplicated the report in report builder 2.0 and it executes through all the records but only displays the first one in the report. My data source is a stored proc.
Dec 11 '12 #1

✓ answered by Rabbit

First let's make sure we're talking about the same program. Are you referring to the business intelligence development studio that comes with SQL server? And you're talking about deploying a report to a SQL server reporting services server?

Share this Question
Share on Google+
8 Replies


Rabbit
Expert Mod 10K+
P: 12,430
What do you mean by you duplicated the report?

Are you aware that you can deploy to different versions of SSRS from one project? There's no need to copy the report for different versions.
Dec 11 '12 #2

P: 6
I wasn't aware of that. Does that mean I can just copy the rdll up to the client and run it. Do I have to creare the datasource and dataset. I am not real familiar with RB--just really starting to get into it.
Dec 11 '12 #3

P: 6
I recreated everything. Its basically a data extraction to be used in a export process. I created the report so the end user can enter simple parameters easily.
Dec 11 '12 #4

Rabbit
Expert Mod 10K+
P: 12,430
First let's make sure we're talking about the same program. Are you referring to the business intelligence development studio that comes with SQL server? And you're talking about deploying a report to a SQL server reporting services server?
Dec 11 '12 #5

P: 6
I am talking about the program 'Report Builder' that comes as part of the SSRS. That version is 1.0, Subseguent versions are 2.0 and 3.0 respectively. These may be downloaded from microsoft. The visual studdio version and the report builder appear very similar.
Dec 12 '12 #6

P: 6
I think I have identified the issue, I need to establish a detail group but the detail group should be the only group. In my working model, the group pane contains ' = detail '
Dec 12 '12 #7

Rabbit
Expert Mod 10K+
P: 12,430
It sounds like you've resolved your issue then?
Dec 12 '12 #8

P: 6
Yes, Thank you very much. Your insight was most helpful..made me think.
Dec 12 '12 #9

Post your reply

Sign in to post your reply or Sign up for a free account.