By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
439,978 Members | 1,373 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 439,978 IT Pros & Developers. It's quick & easy.

SQL backup job - failed

P: n/a
Hi,
Appreciated anyone who can help us with our problem. Our backup job
for ROUTT database has been failing for the last 4 days. It was
working fine for almost a year now. The only thing happened few days
before the problem started is the addition of more memory to the
server because we've been getting the low virtual memory error. There
are two databases in this server so we have two backup jobs everyday.
The other backup job runs with no problem. Can someone give us any
suggestion please. Listed below is the sql log.

Thanks,
Teresa
ROUTT Database Backup Log
[Microsoft SQL-DMO (ODBC SQLState: 42000)] Error 945: [Microsoft][ODBC
SQL Server Driver][SQL Server]Database 'ROUTT' cannot be opened due to
inaccessible files or insufficient memory or disk space. See the SQL
Server errorlog for details.

ROUTT Transaction Log Database Backup Log
[Microsoft SQL-DMO (ODBC SQLState: 42000)] Error 945: [Microsoft][ODBC
SQL Server Driver][SQL Server]Database 'ROUTT' cannot be opened due to
inaccessible files or insufficient memory or disk space. See the SQL
Server errorlog for details.
SQL Sever ErrorLog

2004-04-02 21:16:05.65 spid54 udopen: Operating system error 32(The
process cannot access the file because it is being used by another
process.) during the creation/opening of physical device
D:\MSSQL\MSSQL\Data\ROUTT_Data.MDF.
2004-04-02 21:16:05.65 spid54 FCB::Open failed: Could not open
device D:\MSSQL\MSSQL\Data\ROUTT_Data.MDF for virtual device number
(VDN) 1.

2004-04-05 21:31:06.90 spid57 udopen: Operating system error 32(The
process cannot access the file because it is being used by another
process.) during the creation/opening of physical device
D:\MSSQL\MSSQL\Data\ROUTT_Data.MDF.
2004-04-05 21:31:06.90 spid57 FCB::Open failed: Could not open
device D:\MSSQL\MSSQL\Data\ROUTT_Data.MDF for virtual device number
(VDN) 1.

2004-04-06 00:30:10.89 backup BACKUP failed to complete the command
BACKUP LOG [ROUTT] TO DISK =
N'D:\MSSQL\MSSQL\BACKUP\ROUTT_tlog_200404060030.TR N' WITH INIT ,
NOUNLOAD , NOSKIP , STATS = 10, NOFORMAT

2004-04-06 00:45:01.12 backup BACKUP failed to complete the command
BACKUP DATABASE [ROUTT] TO DISK =
N'D:\MSSQL\MSSQL\BACKUP\ROUTT_db_200404060045.BAK' WITH INIT ,
NOUNLOAD , NOSKIP , STATS = 10, NOFORMAT
Jul 20 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
First and foremost. Ensure your backup drive has enough freespace.
Jul 20 '05 #2

P: n/a
In article <7f**************************@posting.google.com >,
tp****@pepco.com says...
Hi,
Appreciated anyone who can help us with our problem. Our backup job
for ROUTT database has been failing for the last 4 days. It was
working fine for almost a year now. The only thing happened few days
before the problem started is the addition of more memory to the
server because we've been getting the low virtual memory error. There
are two databases in this server so we have two backup jobs everyday.
The other backup job runs with no problem. Can someone give us any
suggestion please. Listed below is the sql log.


Maybe a BIG transaction log and an increase in the DB size? How much
disk space do you have free on the drive you are doing the backups to?
--
--
sp*********@rrohio.com
(Remove 999 to reply to me)
Jul 20 '05 #3

P: n/a
lo************@hotmail.com (louis nguyen) wrote in message news:<b0*************************@posting.google.c om>...
First and foremost. Ensure your backup drive has enough freespace.


I would test that you do a manual backup. This will remove any
problems that you may have regards to scheduling the job. Assuming
that you have enough disk space I'd set up a performance monitor trace
to check the SQL memory and other parameters to check what is going
on.

Ginters
Jul 20 '05 #4

P: n/a
jp*******@talk21.com (John McGinty) wrote in message news:<87**************************@posting.google. com>...
lo************@hotmail.com (louis nguyen) wrote in message news:<b0*************************@posting.google.c om>...
First and foremost. Ensure your backup drive has enough freespace.


I would test that you do a manual backup. This will remove any
problems that you may have regards to scheduling the job. Assuming
that you have enough disk space I'd set up a performance monitor trace
to check the SQL memory and other parameters to check what is going
on.

Ginters


Hi,
Thank you very much for helping us out. It turned out that the
application is still link to the database when the backup ran.

Thanks,
Teresa
Jul 20 '05 #5

P: n/a
jp*******@talk21.com (John McGinty) wrote in message news:<87**************************@posting.google. com>...
lo************@hotmail.com (louis nguyen) wrote in message news:<b0*************************@posting.google.c om>...
First and foremost. Ensure your backup drive has enough freespace.


I would test that you do a manual backup. This will remove any
problems that you may have regards to scheduling the job. Assuming
that you have enough disk space I'd set up a performance monitor trace
to check the SQL memory and other parameters to check what is going
on.

Ginters


Hi,
Thank you very much for helping us out. It turned out that the
application is still link to the database when the backup ran.

Thanks,
Teresa
Jul 20 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.