469,106 Members | 2,258 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,106 developers. It's quick & easy.

Strange Behavior with 2757: There was a problem... error

I'm using Access as the front end to SQL2000.
I have a table of contacts. UniqueID is the PK.
There's also a column named "CreatedBy" int and a column Category
smallint. They're all set to no nulls. If I create an index on
Category, an SP that searches the CreatedBy column fails and I get an
error message: 2757 There was a problem accessing a property or method
of the OLE object.
If I delete that column from the index then the opposite happens with
the same error. I have even deleted the columns, saved the table, and
recreated the columns. This is an aggravating one!
Jul 20 '05 #1
1 1667
Lauren Quantrell (la*************@hotmail.com) writes:
I'm using Access as the front end to SQL2000.
I have a table of contacts. UniqueID is the PK.
There's also a column named "CreatedBy" int and a column Category
smallint. They're all set to no nulls. If I create an index on
Category, an SP that searches the CreatedBy column fails and I get an
error message: 2757 There was a problem accessing a property or method
of the OLE object.
If I delete that column from the index then the opposite happens with
the same error. I have even deleted the columns, saved the table, and
recreated the columns. This is an aggravating one!


I have no idea of what that might be, but if the error message talks
about OLE, I guess this is a message from Access, about which I know
next to nothing.

Did you try running the stored procedure from Query Analyzer?
--
Erland Sommarskog, SQL Server MVP, so****@algonet.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 20 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.