By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,277 Members | 1,161 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,277 IT Pros & Developers. It's quick & easy.

Login failed for user 'sa'. Reason: Server is in single user mode.

P: n/a
aj
SQL Server 2005 SP2 2005.090.3054.00

I'm trying to move master/model/msdb to a new spot. I restart SQL
Server in single user mode with the "-c;-m;-T3608" startup params.

When I try to connect to do the detach, I get:
Login failed for user 'sa'. Reason: Server is in single user mode. Only
one administrator can connect at this time. (Microsoft SQL Server,
Error: 18461)

But no one else is trying to connect....????

I have stopped all other services other than the main MSSQLSERVER server
instance.. same result..

Any ideas appreciated..

aj
Jun 27 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
aj
I found a workaround. I simply used SQLCMD rather than Mgmt Studio. I
guess Mgmt Studio must be trying to make a 2nd connection somehow, but
I don't know why. I scripted this out on my test server beforehand, and
Mgmt Studio connected just fine.... <scratching head>...

aj

aj wrote:
SQL Server 2005 SP2 2005.090.3054.00

I'm trying to move master/model/msdb to a new spot. I restart SQL
Server in single user mode with the "-c;-m;-T3608" startup params.

When I try to connect to do the detach, I get:
Login failed for user 'sa'. Reason: Server is in single user mode. Only
one administrator can connect at this time. (Microsoft SQL Server,
Error: 18461)

But no one else is trying to connect....????

I have stopped all other services other than the main MSSQLSERVER server
instance.. same result..

Any ideas appreciated..

aj
Jun 27 '08 #2

P: n/a
aj (ro****@mcdonalds.com) writes:
I found a workaround. I simply used SQLCMD rather than Mgmt Studio. I
guess Mgmt Studio must be trying to make a 2nd connection somehow, but
I don't know why. I scripted this out on my test server beforehand, and
Mgmt Studio connected just fine.... <scratching head>...
If you have set up Mgmt Studio to open both a query window and an
Object Explorer when you startup, there will be two connections.

Not talking how funny this will be in SQL 2008 with intellisense,
which opens a second connection behind your back.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server 2005 at
http://www.microsoft.com/technet/pro...ads/books.mspx
Books Online for SQL Server 2000 at
http://www.microsoft.com/sql/prodinf...ons/books.mspx
Jun 27 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.