By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,573 Members | 3,017 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,573 IT Pros & Developers. It's quick & easy.

SQL 2000 Database files become read-only after reboot

P: n/a
When I restart the machine, the sql 2000 database files become
"Read-Only".
In the Enterprise Manager this DB is marked as "suspect". After I
remove "read only" attribute form the files, and restart the server,
it works just fine until next reboot. Who knows the reason of this
problem? And How to avoid this situation in the next time? Would u all
mind helping me!????
Jul 20 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Possibly some other process using the file(s) when SQL Server starts. What related messages do you
have in the errorlog?

--
Tibor Karaszi, SQL Server MVP
Archive at: http://groups.google.com/groups?oi=d...blic.sqlserver
"chunman" <ch*****@iloveilove.com> wrote in message
news:39*************************@posting.google.co m...
When I restart the machine, the sql 2000 database files become
"Read-Only".
In the Enterprise Manager this DB is marked as "suspect". After I
remove "read only" attribute form the files, and restart the server,
it works just fine until next reboot. Who knows the reason of this
problem? And How to avoid this situation in the next time? Would u all
mind helping me!????

Jul 20 '05 #2

P: n/a
Hi,
Just "Access Denialed"

Starting up database 'CC_CTIDB'.
2003-11-17 17:32:14.06 spid11 udopen: Operating system error
5(存取被拒。) during the creation/opening of physical device d:\Program
Files\Microsoft SQL Server\MSSQL\data\CC_CTIDB.mdf.
2003-11-17 17:32:14.06 spid11 FCB::Open failed: Could not open device
d:\Program Files\Microsoft SQL Server\MSSQL\data\CC_CTIDB.mdf for
virtual device number (VDN) 1.
2003-11-17 17:32:14.20 spid10 udopen: Operating system error
5(存取被拒。) during the creation/opening of physical device D:\Program
Files\Microsoft SQL Server\MSSQL\data\CC_APSEXT_log.ldf.
2003-11-17 17:32:14.20 spid10 FCB::Open failed: Could not open device
D:\Program Files\Microsoft SQL Server\MSSQL\data\CC_APSEXT_log.ldf for
virtual device number (VDN) 2.
2003-11-17 17:32:14.21 spid11 Device activation error. The physical
file name 'd:\Program Files\Microsoft SQL
Server\MSSQL\data\CC_CTIDB.mdf' may be incorrect.
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 20 '05 #3

P: n/a

"Kenneth Tsang" <ch*****@iloveilove.com> wrote in message
news:3f*********************@news.frii.net...
Hi,
Just "Access Denialed"
Is there any chance the D: drive is a SAN or some sort of RAID that may be
completing startup actions when the server reboots?

Do you have any startup scripts for your server itself (a chkdsk, virus
scan, etc) that may run at boot?

(There's a number of places this may be, but google for entries in the
registry.)


Starting up database 'CC_CTIDB'.
2003-11-17 17:32:14.06 spid11 udopen: Operating system error
5(存取被拒。) during the creation/opening of physical device d:\Program
Files\Microsoft SQL Server\MSSQL\data\CC_CTIDB.mdf.
2003-11-17 17:32:14.06 spid11 FCB::Open failed: Could not open device
d:\Program Files\Microsoft SQL Server\MSSQL\data\CC_CTIDB.mdf for
virtual device number (VDN) 1.
2003-11-17 17:32:14.20 spid10 udopen: Operating system error
5(存取被拒。) during the creation/opening of physical device D:\Program
Files\Microsoft SQL Server\MSSQL\data\CC_APSEXT_log.ldf.
2003-11-17 17:32:14.20 spid10 FCB::Open failed: Could not open device
D:\Program Files\Microsoft SQL Server\MSSQL\data\CC_APSEXT_log.ldf for
virtual device number (VDN) 2.
2003-11-17 17:32:14.21 spid11 Device activation error. The physical
file name 'd:\Program Files\Microsoft SQL
Server\MSSQL\data\CC_CTIDB.mdf' may be incorrect.
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

Jul 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.