By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,759 Members | 1,778 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,759 IT Pros & Developers. It's quick & easy.

ASE ODBC 12.5 Driver has problem with SQLServer 8.0 DTS: HELP!

P: n/a
Hi,

On one side, I have a Sybase 12.5 32 bits Server running on AIX 5.1
(maintenance level 3). On the other, I've got W2000 5.00.2195 (SP2)
with SQL Server Standard Edition, Product Version 8.00.534 (SP2),
having installed MDAC 2.6.

I connect to the Sybase 12.5 database using Merant ASE ODBC driver for
Sybase 12.5, and using the Microsoft OLE DB Provider for SQL Server
that comes with this SQLServer version.

I try to pump over data from Sybase to SQLServer to one table at a
SQLServer user database, using a package containing a select statement
on a View on the Sybase Server side, using an ODBC 12.5 System DSN
pointing to the Sybase server. All privileges are set correctly on
either side and the ODBC datasource test gives an 'OK' on trying to
reach the Sybase Server.

When I do PREVIEW, I get a resultset alright, however, when I actually
run the package as a scheduled job, its keeps on running infinitely
until manually killed. No data at all is inserted in the the SQLServer
table.

Strange thing is, the same processes is running without any
complications on a W2000 5.00.2195 (SP3), MDAC 2.7 system, with the
same SQLServer connecting to the same Sybase Server but using Merant
ASE ODBC 12.0 instead of ODBC 12.5.

How come?

Any help will be greatly appreciated.

Martijn Rutte
Jul 20 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Same permissions for the SQL Server Agent account ?

http://support.microsoft.com/?kbid=269074
--

Allan Mitchell (Microsoft SQL Server MVP)
MCSE,MCDBA
www.SQLDTS.com
I support PASS - the definitive, global community
for SQL Server professionals - http://www.sqlpass.org
"Martijn Rutte" <op****@zonnet.nl> wrote in message
news:80**************************@posting.google.c om...
Hi,

On one side, I have a Sybase 12.5 32 bits Server running on AIX 5.1
(maintenance level 3). On the other, I've got W2000 5.00.2195 (SP2)
with SQL Server Standard Edition, Product Version 8.00.534 (SP2),
having installed MDAC 2.6.

I connect to the Sybase 12.5 database using Merant ASE ODBC driver for
Sybase 12.5, and using the Microsoft OLE DB Provider for SQL Server
that comes with this SQLServer version.

I try to pump over data from Sybase to SQLServer to one table at a
SQLServer user database, using a package containing a select statement
on a View on the Sybase Server side, using an ODBC 12.5 System DSN
pointing to the Sybase server. All privileges are set correctly on
either side and the ODBC datasource test gives an 'OK' on trying to
reach the Sybase Server.

When I do PREVIEW, I get a resultset alright, however, when I actually
run the package as a scheduled job, its keeps on running infinitely
until manually killed. No data at all is inserted in the the SQLServer
table.

Strange thing is, the same processes is running without any
complications on a W2000 5.00.2195 (SP3), MDAC 2.7 system, with the
same SQLServer connecting to the same Sybase Server but using Merant
ASE ODBC 12.0 instead of ODBC 12.5.

How come?

Any help will be greatly appreciated.

Martijn Rutte

Jul 20 '05 #2

P: n/a
Hi Allan,

Exactly the same permissions.

Martijn

"Allan Mitchell" <al***@no-spam.sqldts.com> wrote in message news:<uQ*************@TK2MSFTNGP12.phx.gbl>...
Same permissions for the SQL Server Agent account ?

http://support.microsoft.com/?kbid=269074

Jul 20 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.