By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,364 Members | 1,341 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,364 IT Pros & Developers. It's quick & easy.

SqlCommand TimeOut

100+
P: 233
I have a .net application that is now timing out at a sqlcommand. The app uses SQL Server Express, so I attempted to delete a row, the sqlcommand in question, but the process will timeout there as well. If I try to delete a row using the management studio, same result. I do not see any significant errors in the even log, no changes have been made to my knowledge, so what might cause this to occur. To be clearer, I am point the finger at the db not the application.
May 8 '08 #1
Share this Question
Share on Google+
2 Replies


Delerna
Expert 100+
P: 1,134
Have not used SQL Express myself but maybe you could try some tests like I would If I had the problem with SQLServer 2000.

1) proove it is the db that is slow. I run the query in query analyser to see how long it takes to actually run query on the server.
If it is the query that is slow then you will have to investigate methods to speed it up.

If its not the db then some questions come to mind
1) Has there been an update on the software you are using as the front end
ie if you are using internet explorer, has an automatic update occurred.

Hope this helps you along the way to a solution. You really haven't given us much info to go on.
May 11 '08 #2

100+
P: 233
Ended up being an issue with a table that was growing too large, and in turned the default SqlCommand timeout of 30 seconds was not enough to to perform the query. I cleaned up the table and it appears to be working as expected now... it's so much fun to maintain someone else's project.
May 13 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.