By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,855 Members | 1,970 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,855 IT Pros & Developers. It's quick & easy.

Unable to initialize OraOLEDB from SQL Server 2005 x64 to Oracle

P: n/a
I have a 64 bit SQL Server 2005 SP2 on a Windows 2003 x64. The
developer said that he needed to use OLE to talk to Oracle so I went
to Oracle and downloaded the 64 bit OraOLDDB driver as recommended in
a MS note.

I can connect to Oracle via tnsping and using SQLPlus but I cannot
create a linked db successfully.

The linked database errors off with >Cannot initialize data source
for OLE provider "OraOLEDB.Oracle" for Lined Server "X" (Microsoft SQL
Server error: 7399) << (manually typed)

Here is the official OS, SQL Server, and Oracle client information:

The OS is Windows Server 2003 Standard x64 edition Service Pack 2
(NT 5.2 build 3790)

The SQL Server 2005 9.0.3042 (x64)
[from
Microsoft SQL Server Management Studio 9.00.3042.00
Microsoft Analysis Services Client Tools 2005.090.3042.00
Microsoft Data Access Components (MDAC) 2000.086.3959.00
(srv03_sp2_rtm.070216-1710)
Microsoft MSXML 2.6 3.0 6.0
Microsoft Internet Explorer 6.0.3790.3959
Microsoft .NET Framework 2.0.50727.42
Operating System 5.2.3790

The OraOLEDB.Oracle driver was installed from the Oracle 64 bit
download with a database version of 10.2.0.1.0

Oracle "tnsping sid " works
SQLPlus (ver 9.2) works

I have serveral linked databases to Oracle that I have built but all
of them are 1- on SQL Server 2000 and 2- are 32 bit. If anyone knows
of any additional patches (Windows or Oracle) necessary to resolve
this I would appreciate the information. Also there are potential
firewall issues though the fact that SQLPus can be used seems to rule
this out, but if there are any ports associated with OLE I would like
to check on them specifically.

-- Mark D Powell --

Nov 12 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.