By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,969 Members | 2,250 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,969 IT Pros & Developers. It's quick & easy.

Excel Inserts Null Values in DTS package

P: n/a
Hello all,
I have DTS package that is importing data from multiple large Excel
files from same directory
into 1 database table. The structures are same and sizes of the .xls
files are good.
The problems come after all files are successfully imported.
The problem:
All contents are formatted as General.
I have 2 types of values in same column
First scenario:
1 cell :899990
2 cell :899990AB

When I import it to database
1 cell is imported as 899990
2 cell is imported as NULL

Second scenario:
1 cell :899990AB
2 cell :899990
When I import it to database
1 cell is imported as 899990AB
2 cell is imported as NULL

I understood that If the first cell is number Excel assumes that all
others are numbers as well and vice versa.
We wrote macro that would go to each cell add empty space and format it

as text and does it for each file on the given directory. It worked
fine, but
for 23 files, 599999 lines each it took 10 days for this macro to run
and I need it to be done at least for 2 days.
I tried to add Extended property in Excel Connection to Disconnected
edit
IMEX=1 it works only for the first file, and others are still having
the problems

Is there any other way to fix this problem.
Thank you in advance

Sep 14 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.