By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,574 Members | 1,968 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,574 IT Pros & Developers. It's quick & easy.

Problem moving msdb

P: n/a
Hi,
I am trying to move the msdb database, I am following the MS technet
document. I have added trace flag "-T3608" to startup parameters,
restarted the SQL server, stopped the agent, detatached the msdb
successfully. I moved the mdf and ldf to the new location and I removed
trace flag and when restarted the SQL server is not starting up, I
checked Event log it is giving this error

17052 :Could not find database ID 3. Database may not be activated yet
or may be in transition.

Please help me
Thanks in advance

May 5 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
I believe that database ID 3 is the "model" database.....Did you also
try and move the model database?

May 5 '06 #2

P: n/a
(na*****@gmail.com) writes:
I believe that database ID 3 is the "model" database.....Did you also
try and move the model database?


Correct. msdb is dbid = 4.

Looks like Raj should restore the trace flag, and then check what he
actually moved.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server 2005 at
http://www.microsoft.com/technet/pro...ads/books.mspx
Books Online for SQL Server 2000 at
http://www.microsoft.com/sql/prodinf...ons/books.mspx
May 6 '06 #3

P: n/a
Ah OK, it does sound like the model database has been moved then. From
memory, it has to be re-attached before msdb. Also, model must be
re-attached with the trace flag on but msdb should be re-attached with
the trace flag off...

May 6 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.