472,783 Members | 871 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,783 software developers and data experts.

BACKUP LOG cannot be performed because there is no current database backup

Hi All,

I am facing this issue very frist time. I add a logical device as

USE master


EXEC sp_addumpdevice 'disk', 'AdvWorksData',

'C:\Program Files\Microsoft SQL

-- Create a logical backup device, AdvWorksLog.

USE master


EXEC sp_addumpdevice 'disk', 'AdvWorksLog',

'C:\Program Files\Microsoft SQL

-- Back up the full AdventureWorks database.

BACKUP DATABASE AdventureWorks TO AdvWorksData

-- Back up the AdventureWorks log.

BACKUP LOG AdventureWorks

TO AdvWorksLog

The database backup is completed successfully but log's backup fails
with the following messages:

Msg 4214, Level 16, State 1, Line 1

BACKUP LOG cannot be performed because there is no current database

Msg 3013, Level 16, State 1, Line 1

BACKUP LOG is terminating abnormally.

We are moving from SQL 2000 to SQL 2005. I have ensured that database
has full recovery mode on. We are using SQL 2005 on Windows 2003 Server

Further more, I also created a plan to test it, and plan also fails
when backing up the logs.

Can anyone shed some light on this issue.

Thanks in advance.


Feb 10 '06 #1
1 8965
I never mind guys. I figured out why it was happening. I had scheduled
a job previously that was running truncating the logs i.e.
truncate_only option.

All well that ends well :)

Feb 10 '06 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Cristina | last post by:
Hallo i am a beginner into Oracle Technologies.I would like to make backup of my database,but i dont know how.Is there tools?Can i schedule the backup plan? thanks Cristina
by: Tim Morrison | last post by:
MSDE2000 I have an application in which I am running a TSQL command of BACKUP DATABASE and RESTORE DATABASE for the backup and restore commands for my application. For testing purposes, i did the...
by: TThai | last post by:
Hi, Appreciated anyone who can help us with our problem. Our backup job for ROUTT database has been failing for the last 4 days. It was working fine for almost a year now. The only thing...
by: Hardy | last post by:
hi gurus, now I have to backup and restore a 8 T size db2 database. from two s85 to two 670. the partitions,tablespaces of the db should be redesigned then I plan to use redirected restore. but...
by: uthuras | last post by:
Hi all, I have DB2ESE version 8.1 with FP 4 on AIX 5.2. My database used to be 1.1TB. When the DB size is 1.1TB, it takes approximately 7 hours to backup the entire database (online backup). The...
by: johnm | last post by:
Hello All, I appreciate all of the help with my previous posts. It's nice having such a knowledgeable group to draw upon for help. I have taken all of your previous suggestions to heart and...
by: Webbyz | last post by:
I have a code question. I am trying to figure out how to make a backup of a .mdb database when a user selects the "BackUp Database" option from the MainManu Control I have created. I would like the...
by: NDayave | last post by:
How do, For backing up my database(Access 2000), i am trying to just back up the tables and their data, as this will save on space and allow for importing back into the actual database. I want the...
by: Christian Maslen | last post by:
Hi All, I understand in older versions of DB2/UDB this was not possible. The following article explains how I might do this ...
by: Rina0 | last post by:
Cybersecurity engineering is a specialized field that focuses on the design, development, and implementation of systems, processes, and technologies that protect against cyber threats and...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 2 August 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
How does React native implement an English player?
by: Mushico | last post by:
How to calculate date of retirement from date of birth
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.