469,917 Members | 2,157 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,917 developers. It's quick & easy.

Connecting to Webservice from DTS


I created a custom DTS object that does its work by calling a
webservice. When you create the object in DTS, it lets you set the
user/pw you want to use to authenticate to the webservice. The problem
I am having is that once I authenticate to the webservice within DTS,
it always uses the same authentication when contacting the service.

So, for example, I drop a new instance of my object into a package. It
connects to the webservice as me. I set up the parameters of the task,
including telling it to connect as User="test". If I run it, my code
sets the credentials correctly on the webservice, but the webservice
still gets called as me.

If I exit out of SQL Server and go back in, and run it, it correctly
connects as User="test". But then if I try to edit the task, and give
my own user and password, it still always tries to connect as "test".

It seems whoever I initially connect to the webservice as, that is the
information that DTS will use for the entire session.

Is there any way to do what I want to do?

thanks

Jul 23 '05 #1
1 2070

"Backslider" <ba********@mail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...

I created a custom DTS object that does its work by calling a
webservice. When you create the object in DTS, it lets you set the
user/pw you want to use to authenticate to the webservice. The problem
I am having is that once I authenticate to the webservice within DTS,
it always uses the same authentication when contacting the service.

So, for example, I drop a new instance of my object into a package. It
connects to the webservice as me. I set up the parameters of the task,
including telling it to connect as User="test". If I run it, my code
sets the credentials correctly on the webservice, but the webservice
still gets called as me.

If I exit out of SQL Server and go back in, and run it, it correctly
connects as User="test". But then if I try to edit the task, and give
my own user and password, it still always tries to connect as "test".

It seems whoever I initially connect to the webservice as, that is the
information that DTS will use for the entire session.

Is there any way to do what I want to do?

thanks


I have no idea - you might want to ask in microsoft.public.sqlserver.dts, to
see if someone there knows about DTS caching properties inappropriately.
Since you seem to be saying that your own custom task is not behaving
correctly, you'll probably have to give more details about exactly how
you've implemented it, to make it clear why you believe the problem lies
with DTS and not your task.

Simon
Jul 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Ricky K. Rasmussen | last post: by
2 posts views Thread by TCORDON | last post: by
13 posts views Thread by ShadowOfTheBeast | last post: by
1 post views Thread by kimberly.walker | last post: by
8 posts views Thread by =?Utf-8?B?U3JpcmFtIE1hbGxhanlvc3VsYQ==?= | last post: by
1 post views Thread by Waqarahmed | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.