By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,574 Members | 1,977 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,574 IT Pros & Developers. It's quick & easy.

Reporting Services security issues

P: n/a
Hello All,

I have encountered a problem where the user is asked for their username
and password twice, the first time when the arrive at the site, the
second time when the run the report. Is there a way to prevent the
second logon?

All the users are windows domain account holders, the users and the
reports server/manager are on the same domain.

The second logon prompt appears when they access the reports using the
full url i.e. http://pcname.domain.com/Reports. If the users access the
reports using http://pcname/Reports then they are prompted only once,
and not when they run the report.

IIS and Reports Server have Integrated Windows authentication set and
to connect to the datasource the credentials are stored on the reports
server itself, note that in both cases the reports run properly (in
case of the second logon, after the user enters the username and
password).

I would like to know is anyone has encountered this problem and/or if
they have a solution? Would this require a customization in the
security extension or an alteration in the configuration files?
Thanks in Advance

Hasanain

Jul 23 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.