By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,842 Members | 2,368 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,842 IT Pros & Developers. It's quick & easy.

Two questions about SQL Server 6.5

P: n/a
Hi,

I copied the DATA directory from a backup ghost image to a new SQL
6.5 installation and, after fixing a problem with the directory structure
(which caused the databases to be marked as "suspect") I was able to work
with it in a normal way.

Opening the company database works without problems. The DATA
directory seems to be correctly copied. The only problem is that I'm unable
to see the scheduled tasks. I'm a using predefined database user (not sa).

My questions are:

1. Is it normal not to see the scheduled tasks when logged as
another user than the sa or the owner of the tasks ? If it isn't, then
something went wrong copying the DATA directory (even if SQL didn't mark
them as suspect). Any advise or comment about this would be really welcome.

2. If it's normal not to see the scheduled tasks, Is there any way
to recover the lost sa password ? The docs containing the password were
lost around 4 years ago.

Any help would be really welcome,

Jul 23 '05 #1
Share this Question
Share on Google+
10 Replies


P: n/a
[posted and mailed, please reply in news]

Mist in the night (mi************@hotmail.com) writes:
1. Is it normal not to see the scheduled tasks when logged as
another user than the sa or the owner of the tasks ? If it isn't, then
something went wrong copying the DATA directory (even if SQL didn't mark
them as suspect). Any advise or comment about this would be really
welcome.
I did a test, and indeed as a plain user I was not able to see the
scheduled task as sa.
2. If it's normal not to see the scheduled tasks, Is there any way
to recover the lost sa password ? The docs containing the password were
lost around 4 years ago.


I assume that the server is not configured for Windows Authentication?
But as long as you have Windows admin privilege on the box, this can be
arranged. Go the registry, and find
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\Parameters.
Change LoginMode from 0 to 1. Restart SQL Server.

Now you can connect with Windows Authentication. If you are logged on to
Windows with admin privs, you will be connected as sa. Once there, you
can change the sa password to whatever you like.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #2

P: n/a
Erland,

Thank you for your clear and precise help. I had the domain admin password
and it worked at the first try.

If only I had asked before, it could have saved me two really stressful
days :)

I owe you a beer,

- Juan

Erland Sommarskog wrote:
I assume that the server is not configured for Windows Authentication?
But as long as you have Windows admin privilege on the box, this can be
arranged. Go the registry, and find
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\Parameters.
Change LoginMode from 0 to 1. Restart SQL Server.

Now you can connect with Windows Authentication. If you are logged on to
Windows with admin privs, you will be connected as sa. Once there, you
can change the sa password to whatever you like.

Jul 23 '05 #3

P: n/a
Mist in the night (mi************@hotmail.com) writes:
Thank you for your clear and precise help. I had the domain admin password
and it worked at the first try.


Glad to hear that it worked out!

--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #4

P: n/a
Erland Sommarskog wrote:
I assume that the server is not configured for Windows Authentication?
But as long as you have Windows admin privilege on the box, this can be
arranged. Go the registry, and find
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\Parameters. Change LoginMode from 0 to 1. Restart SQL Server.


I have been trying to recover a lost sa password as well. The SQL Server
is not configured for windows authentication. When I looked in the
registry for the key referenced above, it was not there. The server (very
old) is running NT4 Service Pack 6. I also searched the registry for
local users that registered the sql server in enterprise manager. I found
logins and passwords in the registry but none of them happened to be the
sa password.

Jul 23 '05 #5

P: n/a
SvenOlsen (cf*@ait.com) writes:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer\Parameters.
Change LoginMode from 0 to 1. Restart SQL Server.


I have been trying to recover a lost sa password as well. The SQL Server
is not configured for windows authentication. When I looked in the
registry for the key referenced above, it was not there.


Is the entire Parameters key missing, or is just the LoginMode missing?
In either case, why not just try adding the value and see if it helps?

Of course, an entire key tree is missing this can indicate that the
installation is broken in several ways.

--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #6

P: n/a
The Parameters key is present, however the LoginMode is missing. I tried
adding LoginMode as a string with a value of 1, rebooted the server and I
could not successfully register the sql server in enterprise manager using
a trusted connection. I also tried adding LoginMode as a DWORD but I did
not have any success with that either.

Jul 23 '05 #7

P: n/a
SvenOlsen (cf*@ait.com) writes:
The Parameters key is present, however the LoginMode is missing. I tried
adding LoginMode as a string with a value of 1, rebooted the server and I
could not successfully register the sql server in enterprise manager using
a trusted connection. I also tried adding LoginMode as a DWORD but I did
not have any success with that either.


You did restart the server?

Does "isql -E" work? If not, what is the error message?

I believe the value is a DWORD, but I will have to double-check when I
come home.

--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #8

P: n/a
I completely rebooted the server after creating both keys. I did not try
using ISQL however, I'll do that and post results.

Jul 23 '05 #9

P: n/a
I completely rebooted the server after creating both keys. I did not try
using ISQL however, I'll do that and post results.

Jul 23 '05 #10

P: n/a
SvenOlsen (cf*@ait.com) writes:
The Parameters key is present, however the LoginMode is missing. I tried
adding LoginMode as a string with a value of 1, rebooted the server and I
could not successfully register the sql server in enterprise manager using
a trusted connection. I also tried adding LoginMode as a DWORD but I did
not have any success with that either.


Ah! It turns out that my posting was incorrect. The key is
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\ MSSQLServer, one level
up from what I posted. It is under this key you should find LoginMode. And,
yes, it is a DWORD.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 23 '05 #11

This discussion thread is closed

Replies have been disabled for this discussion.